Qlik Community

Ask a Question

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
Join this live chat April 6, 10AM EST - QlikView to Qlik Sense REGISTER
cancel
Showing results for 
Search instead for 
Did you mean: 
vireshkolagimat
Creator III
Creator III

Getting 0 records while reading data from oracle database

Hi All,

I'm trying to load data into Qlikview (using ODBC connection) from the oracle database(views) but the query is executing fine and not getting any records.

If i query the same view in the SQL Developer IDE, i can see the data.

Please let me know if anybody have faced similar issue.

Thank you.

Regards,

Viresh

10 Replies
settu_periasamy

can you check your log file?  Is that showing any records read?

vireshkolagimat
Creator III
Creator III
Author

Hi, It says 37 fields found , 0 lines fetched.

Regards,

Viresh

settu_periasamy

Ok. are you using any filter (with where condition)?  May be it doesn't met the criteria.

Can you try to remove the filter and execute that?

vireshkolagimat
Creator III
Creator III
Author

Hi, I am not using any filter. The query looks like select * from view_name;

settu_periasamy

Are you really sure do you have the data for the table view_name?  (view_name is a view or table)

if it is view name, can you try load any other table name?

vireshkolagimat
Creator III
Creator III
Author

Hi,

view_name is a view.

The connection sting looks like below.

ODBC CONNECT TO [newebs;DBQ=EBS ] (XUserId is HFVUIcBPFDeKGZBOZE, XPassword is eQaMHcBPFDeKGZBOSA);


select * from apps.xxegc_QV_sales_order_v;


One more thing is, i can query some other tables but not the above view.


Regards,

VK

settu_periasamy

ok. Can you check this.    Extracting views from Oracle

vireshkolagimat
Creator III
Creator III
Author

The same query select * from view_name just works fine and fetches the data. In this case my back end database (Oracle EBS) and Qlikview desktop  are on the same domain.

I am facing issue while connecting the Qlikview desktop from other domain.

Is that causing the issue?

vireshkolagimat
Creator III
Creator III
Author

Hello,

I have added sql alter session set nls_language = 'AMERICAN'; statement after connection string and able to load the data.

Regards,

Viresh