Skip to main content

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

CUSTOMERS ONLY: Now accepting customer applications for the 2023 Luminary Program: SUBMIT NOW
Showing results for 
Search instead for 
Did you mean: 
Not applicable

How can I read a single character SPACE in XML file?

I am trying to read different separators from an xml language file.

This works fine for all characters except for the case when space shall be separator. Note that here is a  white space between the <sv> </sv> tags.

   <comment>1 character separator "translated" according to language</comment>
   <sv> </sv>


When this is loaded in qlikview the field is emptied i.e the space-character  is removed, i'm guessing some trimming has occurred.

Is there any way to state the space to make qlikview keep it when loading the xml-file?

I've tried with different ' 'and  " " and also with some ascii and hex coding for "Space" as value, without any success.



2 Replies

Add this to your script before the load statement:

set Verbatim = 1;

It will prevent stripping spaces. You may want to reset it afterwards to 0.

talk is cheap, supply exceeds demand
Not applicable

Use Verbatim function


Normally all field values are automatically stripped of preceding and succeeding blank characters (ASCII 32) before being loaded into the QlikView database. Setting this variable to 1 suspends the stripping of blank characters.


set Verbatim = 1;