Qlik Community

Ask a Question

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Join us at the Cloud Data and Analytics Tour! REGISTER TODAY
Showing results for 
Search instead for 
Did you mean: 

How can the Top N of something be shown in a table in a QlikView Report?

I am having a problem getting a straight table to display correctly in a QlikView report...

If the table has one dimension and then a count of something (let's say Revenue) against each, I can sort by descending revenue aand see a list that shows which is top, 2nd top and so on... but it shows every dimension with revenue (I suppress zeroes).

When I place this table in a QlikView report it displays fine... dimensions on the left and values on the right

BUT... I want the table to only show the Top N (let's say Top 5).

So I set the Dimension Limits to "Restrict which values are displayed using the first expression" and I put the number 5 in the Show Only largest ... box.

I also untick the option to see a value for Others.

Now when I print the report the format of the table has changed!

The font is much larger. The dinmension list goes down the middle off the page, and I can't see the values

It took a while for me to realise that the table looks fine when there are no dimension limits... but when I did I switched to using the Rank function in the expression... but I get the same result

I have tried making rank a hidden column, set to zero if > 5, and then referencing that column in the visible expression. All of these options look fine in the dashboard... but again the print format is no good. Large, and only the dimension visible... in the middle of the page!!

I even tried simply squeezing up the left hand column to bring the volumes further over to the left, but this change has no effect.

It is as if the presence of the RANK function, either in an expression or indirectly by using Dimension Limits, corrupts the format of the straight table in the printed report!

Has anyone else experienced this?

Is there a clever workaround that I haven't thought of?

If so, I would love to hear it!



0 Replies