Qlik Community

Ask a Question

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
On May 18th at 10AM EDT we will answer your QlikView questions live. REGISTER
cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

How to Edit tooltip of extension object googlemaps marker (By alexandar)

HI,

I am using the extension object written by alexandar for using googlemaps cluster and marker. The marker only show the value of the measure expression. I want to show the location and few other calculations in the tooltip. Can someone please tell me how can I edit the tooltip of the attached extension. I am sure many of you might have used this extension object before

Arif

3 Replies
Alexander_Thor
Employee
Employee

Hey,

Currently there is no pop-ups for the cluster itself but you can change it for the markers.

Simply include some free text in your expression, it also supports any HTML tags you can think off.

For example:

='<b>This is my measurement:</b> ' & Sum(MyField)

or

='<p> This is a paragraph </p>' & Count(QlikViewField) & '<a href="some url">Click me!</a>'

Attached is also a later version of the same extension. In this version your expression value will also aggregate accordingly within the cluster and display the value in the cluster icon. Previously it only showed the number of markers within the cluster.

Not applicable
Author

Hi Alex,

Many thanks for your help. The trick worked really well. However, I see a little issue in the tooltip. It wraps up the detail in tool tip and there is no way to scroll it down. Is there anyway to force it so that the tooltip windows gets bigger if we are showing a little more detail in the tool tip. Please see the attached image

map.png

Syed

Not applicable
Author

Another thing that I just tried the below expression

='Number of Sales: ' & Count(sales)

& '</br> Invoice Number: ' & Inv

& '</br> Dated: ' & InvDate

while the Inv and InvDate are both fields. However the tooltip is showing empty value here. If I turn the webview off and try the same expression in a text box, the values come fine. Any idea what could be the issue here?

Syed