Qlik Community

Ask a Question

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
Join this live chat April 6, 10AM EST - QlikView to Qlik Sense REGISTER
cancel
Showing results for 
Search instead for 
Did you mean: 
dunnalahk123
Creator III
Creator III

How to Fix Column Width in straight table

Hi,

Can Some One Help me , when i try to add 3 Fields in my straight table its width is creating problem.

below are the fields

     Growth_Strategy_and_Innovation_Text,

     Obstacles_and_Challenges_Text,

     Current_Happenings_Text,

i am attaching the report for your reference. can some one help me when i add above fields my borders should not disappear and my table box width should not extend.

Best Regards,

HK

1 Solution

Accepted Solutions
Sergey_Shuklin
Specialist
Specialist

Unfortunately, you'll have to size columns everytime after adding a new field in that table. I've added another two column which you point, but I strongly recommend to do domething with this huge field. It brokes the project.

View solution in original post

10 Replies
Sergey_Shuklin
Specialist
Specialist

Hello, HariKiran!

First of all you are using a table box instead of a straight table. Table box shows fields as they are. But field Growth_Strategy_and_Innovation_Text contains to much symbols (even hidden, like a space), so you get your "problem".

To avoid this you can use a straight table as it is. Use your text fields in expressions (at least you always have an option to use Left() function):

table_width.png

You also can use some string functions in the script like Trim(), Replace(), Left() for trasforming your input data.

And one recommendation (if you don't mind) - don't use such a huge tables, they are unreadable.

dunnalahk123
Creator III
Creator III
Author

Hi,

Thank You. i will take a look with Straight Table as well.

So there is nothing much we can do in table Box with those Fields?

Best Regards,

HK

Sergey_Shuklin
Specialist
Specialist

Well, you can also use an autowidth option:

table_width2.png

RMB click on field which width you want to use for other fields and select "Equal Column Width".

Anil_Babu_Samineni

One possible solution my end is you may re constrain the field names to short then work on it as per there business to better understand

Before develop something, think If placed (The Right information | To the right people | At the Right time | In the Right place | With the Right context)
dunnalahk123
Creator III
Creator III
Author

Hi,

Thank You.

You mean in table box you are asking me to Right Click on it and select Equal Column Width? but if i try to do so it is Disable for me.

or can you show me in the attached Qvw File?

Best Regards,

Hari

Sergey_Shuklin
Specialist
Specialist

Someone had turned off parameters to move/size your table, so you get option "Equal Column Width" disabled:

table_width3.png

I'm also attaching your file back with result.

dunnalahk123
Creator III
Creator III
Author

Hi Shuklin,

Thank You so Much this is what i want.

but i took your attachment QVW and i tried to add my other 2 fields as well but again i am facing same issue it is expanding completely.

may be i am doing some thing wrong. sorry for that

!

dunnalahk123
Creator III
Creator III
Author

After adding those fields i clicked on Equal Width  but still it is like that only.

Sergey_Shuklin
Specialist
Specialist

Unfortunately, you'll have to size columns everytime after adding a new field in that table. I've added another two column which you point, but I strongly recommend to do domething with this huge field. It brokes the project.

View solution in original post