Qlik Community

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
Join “Do More With Qlik” with Mike Tarallo to get a first-hand look at the New Authoring Experience, June 29th: REGISTER HERE
cancel
Showing results for 
Search instead for 
Did you mean: 
julioarriaga
Creator II
Creator II

I can't move objects within QlikView Server Performance

I tried the following things with a newly created object (Current Selection) and also with the already existing objects, but I can't figure out how to move objects within this application -with other applications works just fine-:

* I tried selecting and that in Properties -> Layout -> Options -> Allow Move/Size was checked.

* I tried selecting and pressing Control and tried to move with the directional arrows.

* I checked that in Properties -> Caption -> Show caption was checked.

* I checked that in Sheet Properties -> Security had all the options enabled for movement.

* I tried cloning the object and moving the clone.

Thanks in advance.

Capture.PNG

1 Solution

Accepted Solutions
trdandamudi
Master II
Master II

You can also try as below:

Go to Settings

Select Document Properties

Select "Security" tab

Under User Privileges, Check " Admin Override Security"

Click Ok.

Now you should be able to move the objects with mouse.

Hope this helps...

View solution in original post

9 Replies
sunny_talwar

Did you try changing the x-pos and y-pos on the Caption tab to see if those move the object... This is not the most ideal way to move things, but just to check if the object is moving at all or not

julioarriaga
Creator II
Creator II
Author

Yes, thank you, that moves the object, but is there a way to be able to move the object with the mouse?

sunny_talwar

Can you try moving it using the Ctrl + Arrow (or Ctrl + Shift + Arrow for 10 pixels at a time)? See if that works

julioarriaga
Creator II
Creator II
Author

In this particular app that doesn't work but it works in other apps.

trdandamudi
Master II
Master II

You can also try as below:

Go to Settings

Select Document Properties

Select "Security" tab

Under User Privileges, Check " Admin Override Security"

Click Ok.

Now you should be able to move the objects with mouse.

Hope this helps...

julioarriaga
Creator II
Creator II
Author

Thanks a lot, that worked; I really appreciate it. But I have another question: what security configuration could inabilitate moving the objects within an application?

trdandamudi
Master II
Master II

You are welcome....

Settings ---> Sheet Properties ---> Security Tab will inabilitate movement of objects with in a application.

Hope I answered your question..

julioarriaga
Creator II
Creator II
Author

Well the odd thing is that configuration you mention had the objects habilitated for movement. I just want to know what configuration got the movement of the objects deactivated

trdandamudi
Master II
Master II

Is it possible to share a sample.... ?