Skip to main content
Announcements
Qlik Connect 2024! Seize endless possibilities! LEARN MORE
cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

IF statement with nothing in else condition.

I am making a pivot table with one of the dimensions as hour of the day. I want each hour to be shown as a column in the table and I would like the hours to be between 8 and 23 hrs. so i used a calculated dimension with the IF statement saying that if hour >=8 and <=23,hour.I did not put any else condition.  It works fine except that there is now a column with a no name. I think it is for those values that satisfy the else condition. I donot want that column to be there in the table. How do I proceed with that?

Thanks.

1 Solution

Accepted Solutions
PrashantSangle

Hi,

Check Supress when value is null in Dimension tab.

Or You can create that field in script and use it in your chart.

Regards

Great dreamer's dreams never fulfilled, they are always transcended.
Please appreciate our Qlik community members by giving Kudos for sharing their time for your query. If your query is answered, please mark the topic as resolved 🙂

View solution in original post

4 Replies
PrashantSangle

Hi,

Check Supress when value is null in Dimension tab.

Or You can create that field in script and use it in your chart.

Regards

Great dreamer's dreams never fulfilled, they are always transcended.
Please appreciate our Qlik community members by giving Kudos for sharing their time for your query. If your query is answered, please mark the topic as resolved 🙂
raman_rastogi
Partner - Creator III
Partner - Creator III

-> You can Check Suppress when value is null in Dimension tab.

avinashelite

You can achieve it in 2 ways.

Add a calculated dimension and then check the supress null option in the dimension tab and check the supress null option the presentation tab too.

or

Add the dimension as it is and in the expression add the condition to filter only the hours you required using the set analysis or if condition this will improve the performance too (check the supress null option in the presentation tab)

Not applicable
Author

ohh my bad! missed out on such a small thing. It worked.Thanks!