Qlik Community

Ask a Question

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
Join this live chat April 6, 10AM EST - QlikView to Qlik Sense REGISTER
cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

Inputbox - programmatic definition of the predefined list of drop down options

Hi

I need to create a predefined list of options for a drop down list associated with an inputbox. Unfortunately, I don't know the list of options for the drop down selection list until the data is loaded from the database.

I use the data from the inputbox to control a very specific chart. I don't not want to use a list-Item, as a selection here, will changes the overall selected set.

I can get the Inputbox and drop down list to work if I hand create the list of options in the inputbox's constraints properties.

What I would like to do is define a variable. At data-load time, I process the data, and create the list of options string (option1;option2;option3) for the inputbox, assign to the variable then reference it directly in the inputbox->constraints.>predefined List.

I have tried many different options to deref the variable, but inputbox will not interpret the variable data as a valid list of options.

What am I doing wrong?

Many thanks

Jim

3 Replies
johnw
MVP
MVP

Honestly, it looks bugged to me.

If I type in a value like A;B;C, then it gives me the list. But there's the button with '...' on it, indicating that I can enter an expression. But if I enter ='A;B;C' as an expression, then it interprets it as a SINGLE value. It's like the logic for breaking apart an expression into the values is failing to execute on an expression. I may just don't know what I'm doing, but the help text doesn't even indicate that you CAN type in an expression, so it's no help. In fact, it appears to be wrong, stating that alphanumeric values should be in single quotes, when in fact that causes single quotes to appear in the drop down list.

So I'm no help. Anyone know how to do this or know for sure that it's not working as intended?

Not applicable
Author

Hi John,

I found the following works, even although the documentation says a ';' should be the delimiter. This creates a list of the field values and sticks a ',' between each. When used in the predefined list config, it delivers the results.

Thanks to Rainer F

concat(TOTAL Groups.group_name,',')

Thanks
JIm


johnw
MVP
MVP

Hah! Yeah, methinks they have some bugs here. Semicolon if typed directly, comma if using an expression. Surely that can't be intended. Ah, well. At least you solved it (or Rainer did, anyway), and I've learned something. 🙂