Qlik Community

Ask a Question

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
On May 18th at 10AM EDT we will answer your QlikView questions live. REGISTER
cancel
Showing results for 
Search instead for 
Did you mean: 
Michael_Reese
Employee
Employee

Issue using inputfields

I am trying to create a note field and add it to a table.  I've tried this a number of different ways, but every time I try to add it to a table (which has not been created yet), it loses the input funcitonality.

I can create the input field in it's own table with a load * inline and it works fine if I leave it there, but that's not where I need it.

I have tried adding the field to the table I need it in using a left join, but the value turns to 0 (even though was created as 1), and the editing functionality is lost.

I've also tried creating the input field without using an intermediate table.  Following the creation of the field, I create another table with a field matching the name of the input field.  That doesn't work either.

Here are examples of what I tried that don't work:

Ex1.

inputfield TerritoryNote;

Territory:

Load TerritoryID,

1 as TerritoryNote

;

SQL Select TerritoryID from Territory;

inputfield TerritoryNote;

Territory:

Load * inline [

TerritoryNote

1];

Ex 2.

left join (Territory)

Load TerritoryID,

;

SQL Select TerritoryID from Territory;

1 Solution

Accepted Solutions
Michael_Reese
Employee
Employee
Author

Table was not distinct.

View solution in original post

1 Reply
Michael_Reese
Employee
Employee
Author

Table was not distinct.

View solution in original post