Qlik Community

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
Customer & Partners, DEC. 9, 11 AM ET: Qlik Product & Strategy Roadmap Session: Data Analytics REGISTER NOW
cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

Line chart

Hello

somebody can tell me how to erase the gray sidebars of this line chart?

Thanks

1 Solution

Accepted Solutions
jjfabian
Partner
Partner

Hi,

it is pretty much like Celambarasan said, Qlikview will automatically align to the center so that the gaps will be there.

I've tried looking at your file. While it isn't particularly elegant, multiplying your line chart might give you the look of what you want. Basically it is two line charts on top of each other. The one that actually contains the chart is much larger an transparent, so it can see the scale of the second chart.

Maybe somebody has a more elegant solution that this?

View solution in original post

16 Replies
jjfabian
Partner
Partner

Hi Oronzo,

Try making your chart's background white in the colors tab of your chart.

Not applicable
Author

Hi Jakob,

my background is already white. It seems a problem with offset axis

Thanks

Oronzo

jjfabian
Partner
Partner

In the style tab, try setting the plot area background style to minimal.

If your current setting was frame, then the color change would not do anything.

Not applicable
Author

Hi Jakob ,

if  I  change from frame to minimal I have always 2 sidebars white, I don't want to have sidebar

Thanks

Oronzo

jjfabian
Partner
Partner

Ok, then also try setting the transparency of the frame background color to 100%

Now there should be no bars at all.

Not applicable
Author

Hi Jakob,

I have tried to do that, but I still haven't the desired chart.

I put in attachement what I'm looking for. I don't want to have the 2 areas with "NO"

Is it possible?

IMG3.PNG

jjfabian
Partner
Partner

QlikView is always going to render those areas left and right of the actual bar when your using a bar chart.

Maybe you can try using a gauge here instead and set it up in a manner that it fills to your value.

CELAMBARASAN
Partner
Partner

Hi,

     Check whether you have used Backcast and Forecast options in the Axes tab if so then uncheck the both options.

Celambarasan

Not applicable
Author

Thanks for your answer but

Backcast and Forecast options are unchecked.

Oronzo