Qlik Community

Ask a Question

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
On May 18th at 10AM EDT we will answer your QlikView questions live. REGISTER
cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

Loading sharepoint list via RPC-calls/owssvr.dll - works on main site but not sub-site

Hi,
I am using QV 9.00. and trying to load a sharepoint list.
I get it to work against the main site, but as soon as I try against a sub-site list I get an error message.

I am using the Wizard, Web Files -> Internet File -> enter the address:
http://MAINSITE/SUBSITE/_layouts/_vti_bin/owssvr.dll?Cmd=Display&XMLDATA=1&RowLimit=0&List={1D55BBCF...}
-> checks in "XML" and it shows an error message:
"XML Document must have a top level element. On line number: 0. On Column number: 0 System ID <some text I cant read because it cuts if off...>."

Is there any tricks to writing the sub-sites address or list name? I am using the url under Site Settings "Site URL: XXXX"
Have tried multiple main site lists now and they all seem to work. Must be my URL or sub-site settings, or?...

Any ideas please? Getting desperate...
Kind Regards,

PS. Thanks to Nimish Shah in this thread: http://community.qlik.com/forums/t/24166.aspx for getting me this far! DS.

4 Replies
Not applicable
Author

Ah, how silly!

I had to have ID in the list - actually thought of this but had "ISSUE ID" not "ID" - as soon as I added this it worked like a charm.

Not sure if I should remove this thread, but perhaps someone stumbles across the same issue!

Not applicable
Author

Hi gislo,

Could you please elaborate with an example?

Thanks,

AD

salto
Specialist II
Specialist II

This post has been helpful for me: I was suffering the same problem.

Qlik can retrieve data from Sharepoint List VIEWS. If no specific view is selected in the URL, the default view will be used.

And the ID field of the list must be selected in the View. Otherwise it will not work.

In Sharepoint, I added the ID field of the list to the view (default) that I was trying to retrieve... and voilá!

Not applicable
Author

This hint of Josetxo helped for me, thanks!