Qlik Community

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
QlikWorld 2022, LIVE in Denver CO., May 16-19, 2022. REGISTER NOW TO RECEIVE EARLY BIRD PRICING
cancel
Showing results for 
Search instead for 
Did you mean: 
amayuresh
Creator III
Creator III

Macro Security Dialog

Hi,

I have application with "Export to Excel" Macro. When I am sharing this application to another user, below dialog box showing.

I did setting at module level as:

Requested Module Security = System Access

Current Local Security = Allow System Access

How can I hide this dialog box for all users ?

Is there any setting at document level ?

1 Solution

Accepted Solutions
marcus_sommer
MVP & Luminary
MVP & Luminary

You could hide these dialog only if you adjust the settings.ini from each user in an appropriate way. But if the user press the third radio-button and the option below them "Always ..." those dialog appeared only once - whereby it's not quite clear to me why the last option is greyed out, maybe some security settings related to macros must be enabled within the qmc or document properties.

- Marcus

View solution in original post

6 Replies
marcus_sommer
MVP & Luminary
MVP & Luminary

You could hide these dialog only if you adjust the settings.ini from each user in an appropriate way. But if the user press the third radio-button and the option below them "Always ..." those dialog appeared only once - whereby it's not quite clear to me why the last option is greyed out, maybe some security settings related to macros must be enabled within the qmc or document properties.

- Marcus

View solution in original post

amayuresh
Creator III
Creator III
Author

Is there any other way to hide this ?

amayuresh
Creator III
Creator III
Author

This file is not on Server. We are using it on desktop. Because of this may be that last option is disable.

marcus_sommer
MVP & Luminary
MVP & Luminary

This is not a server setting else it's a user-setting and this settings.ini reside within the user-profile of each user - it's quite the same like the execute-macros settings by MS office. This meant you couldn't change it simply - but your IT would be capable to change this with adding/adjusting a start-script during the logon-process on windows. Otherwise you have to deal with these dialog.

- Marcus

tamilarasu
Champion
Champion

I guess, If the user press the "Allow Safe Macros" option, they will not see this prompt again for the specific document. If the code is modified in the document, users will be prompted again.

Below link might be helpful.

Getting rid of the "Module Security for Documen... | Qlik Community

coyjohn1
Contributor II
Contributor II

I recently had the same error and set my document security to:

Requested Module Security

System Access

And

Current Local Security

Allow System Access

Additionally I also Checked on Change Module Security Dialogue box

Give System Access to Module Script

This has not resolved my issue. Are there any other settings I need to look at?