Qlik Community

Ask a Question

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
Join us at the Cloud Data and Analytics Tour! REGISTER TODAY
cancel
Showing results for 
Search instead for 
Did you mean: 
surynnchin
Contributor III
Contributor III

Multicolored not working

Hi Community

For the combo charts, i want to show the bars in multicolor. I put this in my background expression:

color(fieldindex('Dim1',Dim1)). And it works!! But only if i open from desktop.

test3.jpg

Because when i open the application through acess point or open in server, all the bars are in black. Got any ideas how to solve this? Thanks in advance.

test1.jpg

test2.jpg

5 Replies
qlikpahadi07
Specialist
Specialist

Hi SurynnChin,

This is not a Qlikview behavior and I cross checked on my server your application is working fine both in IE/Ajax.

Server QV11 SR1 Dev and Server.

Not applicable

Hi SurynnChinn,

I'm agreed with QlikPahadi07 your app working fine with my server as well.

danieloberbilli
Specialist II
Specialist II

Its because of FieldIndex - there is problem in some versions with the server where fieldindex returns 0 which leads to the black color in your case. Just try to use another function instead and it works fine 

surynnchin
Contributor III
Contributor III
Author

I'm using QlikView Server 11.2. Do you think that this is a bug?

danieloberbilli
Specialist II
Specialist II

Its a bug but it might also depend not only on the server but also on the IE plugin vresion and desktop version. I think in your case its not difficult to find another expression instead of fieldindex. But have a closer look at other objects where you use fieldindex as an expression as it might work nowhere in your app