Skip to main content

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

cancel
Showing results for 
Search instead for 
Did you mean: 
kevinpintokpa
Creator II
Creator II

NullAsValue not working?

I have some very straightforward code that should work but simply doesn't:

NULLASVALUE *;
SET NullValue ='NA' ;

LOAD
*
FROM
MyFile.qvd
(qvd);

The code executes without errors as shown in the script:

05/28/2013 11:20:51 AM: 0034  NULLASVALUE *
05/28/2013 11:20:51 AM: 0035  SET NullValue ='NA'
05/28/2013 11:20:51 AM: 0038  LOAD
05/28/2013 11:20:51 AM: 0039   *
05/28/2013 11:20:51 AM: 0058  FROM
05/28/2013 11:20:51 AM: 0059  MyFile.qvd

But it has no effect whatsoever if you look at the attached picture.

What am I doing wrong?  I have exactly the same problem on two different computers, running QlikView 11.00 SR2 and 11.20 SR1.

1 Solution

Accepted Solutions
Not applicable

Optimised QVD loads do not reprocess the data within the QVD row by row and

thus it will not apply the NullValue to the data. To get around this you must

force an unoptimised load of the QVD. You can add the WHERE clause to get around this

LOAD

    *

FROM myfile.qvd (qvd)

WHERE 1=1;

View solution in original post

4 Replies
Not applicable

Optimised QVD loads do not reprocess the data within the QVD row by row and

thus it will not apply the NullValue to the data. To get around this you must

force an unoptimised load of the QVD. You can add the WHERE clause to get around this

LOAD

    *

FROM myfile.qvd (qvd)

WHERE 1=1;

shree909
Partner - Specialist II
Partner - Specialist II

Hi Use this

SET NULLDISPLAY= NA;

or SET NULLDISPLAY= 'NA';

kevinpintokpa
Creator II
Creator II
Author

Thanks a ton!  This was driving me crazy.

mongolu
Creator
Creator

GREAT DUDE