Qlik Community

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
We value your feedback – take our 5-minute QlikView modernization survey
cancel
Showing results for 
Search instead for 
Did you mean: 
sanchayan
Creator
Creator

OnPostReload action not functioning even through manual QV Reload :

Hi All,

I have a qlikview doc with a Macro to change the encoding of a file. The Macro when tested works fine and does the needful by changing the encoding of the file. The problem occurs when :

  • I am adding this macro as a OnPostReload action, as its not triggering at all even via Manual Reload.

  • My main requirement is to run the QV file through a batch, so I have tried reloading both with /r and /l. Also, have used the /noSecurity parameter. But the macro just doesn't trigger in any way, neither Manually nor through a batch!!! Yet when tested via the Macro "Test" button, the desired file is generated with correct encoding...

Does the Macro Name we give has something to do with this or is it like we can set any name for the Macro?

I am stuck on this for quite some time now. Please help...

Regards,

Sanchayan Bhowmik

1 Solution

Accepted Solutions
sanchayan
Creator
Creator
Author

Hello,

I mistakenly was using the Macro Name different from the Module Name which is called during the execution and hence even from QV Desktop it was not triggering.

The issue is now solved!

Regards,

Sanchayan Bhowmik

View solution in original post

3 Replies
olivierrobin
Specialist III
Specialist III

hello

if you reload it via QMC, the macro won't be executed by server

reload it with desktop client

sanchayan
Creator
Creator
Author

Hi Oliver,

I am aware about the server limitations. The issue is that I am not able to execute the macro even via QV Desktop client Reload. The macro when Tested manually performs the required functionality but just doesn't trigger via Desktop or via Batch commands,

Regards,

Sanchayan Bhowmik

sanchayan
Creator
Creator
Author

Hello,

I mistakenly was using the Macro Name different from the Module Name which is called during the execution and hence even from QV Desktop it was not triggering.

The issue is now solved!

Regards,

Sanchayan Bhowmik