Skip to main content
Announcements
Do More with Qlik - Qlik Cloud Analytics Recap and Getting Started, June 19: REGISTER
cancel
Showing results for 
Search instead for 
Did you mean: 
devans_1
Creator
Creator

Oracle OLE DB Connection issue

Hi All,

I am trying to connect to an Oracle DB via OLE DB. I have Oracle installed and QlikView installed and my understanding is that when I select 'connect' on the edit screen, the connection should be listed. But it isn't. We have other developers with the same setup and it appears for them. Does anyone have any advice on what is wrong ?

Thanks.

7 Replies
Gysbert_Wassenaar

Make sure the Oracle OLEDB driver was installed on your machine. You may need to use the custom install option of the Oracle Client installer to select the OLEDB driver as one of the components that will be installed.


talk is cheap, supply exceeds demand
devans_1
Creator
Creator
Author

I believe it is installed. I am seeing

Am I missing something ?

awhitfield
Partner - Champion
Partner - Champion

Are those not ODBC drivers?

Andy

Gysbert_Wassenaar

Yup, that's the ODBC driver, not the OLEDB driver.


talk is cheap, supply exceeds demand
Gysbert_Wassenaar

Try creating a text file and save it with a .udl extension: test.udl. Doubleclick that file and a dialog for editing oledb connections will open. On the Provider tab you should see an item in the list called Oracle Provider for OLE DB. If you don't see that provider listed then you're missing a driver.


talk is cheap, supply exceeds demand
devans_1
Creator
Creator
Author

Thanks for your help. Yes, looks like I don't have the driver so I will need to get this from the IT guys....

Not applicable

Thanks bro, it was helpful