Qlik Community

Ask a Question

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
Support Cases coming to Qlik Community Oct. 4! Start chats, open cases, explore resources: READ DETAILS
cancel
Showing results for 
Search instead for 
Did you mean: 
Michal83
Contributor II
Contributor II

Pivot table measures in rows move to columns after conditional dimension update

Hi,

It is my first post on this forum, but I used it a lot in the past and it answered a lot of my questions. But for this one I couldn't find the answer.

I created a PIVOT report, which has some conditional dimensions that are enabled or disabled if a user selects data from a list table. And it works properly, but whenever I change a dimension, measures are moved from the row section to the column section. It is hard to describe it, so I posted a video, where this issue appears.

https://www.youtube.com/watch?v=gL2NTrGPftM

If you know if there is any way to always keep measures in the rows, I would really appreciate your help.

If something is unclear or other information would be needed to help to solve this issue, let me know.

Michal

4 Replies
eddie_wagt
Partner
Partner

Hello Michal,

Could you test the QVW. Made it up very quickly with demo data. There are many ways to implement ad hoc reporting and I cannot see what your solution is. Therefore it is hard to help you, but if you can test the qvw and see if the result is the same then we can take some steps to narrow the problem.

Regards

Eddie

Michal83
Contributor II
Contributor II
Author

Hi Eddie,

Thanks for a fast reply. I followed your suggestion and created a new report on Dummy data that uses the same solution, and it seems to work properly on my local computer, but when doing the same thing on server, the issue remains. Server is running on older version, so maybe that is the reason for this issue. I will investigate it further and come back to you when I find the solution.

Once again, thanks for support,

Michal

eddie_wagt
Partner
Partner

Hello Michal,

No problem. Hopefully you can get some new results from your investigation. I saw a solution which may work in your situation, but I doubt it because you made a new document right?

In some way I cannot link to it, but you will be able to find it by searching Pivot table in access point showing columns as rows. https://community.qlik.com/t5/Qlik-Sense-App-Development/Pivot-table-in-access-point-showing-columns...

Maybe you can also check the user settings in Access Point or let another user test?

 

Regards

Eddie

Michal83
Contributor II
Contributor II
Author

Hi Eddie,

Thanks again for another hint, but  this doesn't seem to be the problem in my case.  I was testing it using the app and I am almost 100% that the issue is due to the QV version. The test file that you suggested to create, works properly on my local computer (QV version 12.50.20300.0), but on the server or on the other user computer (QV version 12.20.20300.0) the issue exist. 

I am attaching the test file in case someone would like to test in case they have the same problem.

Unfortunately it will take some time to update the server version,  but once it's done I will check it and inform if the topic can be closed.

Once again thanks for the support,

Michal