Qlik Community

Ask a Question

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
Support Case Portal will move to Qlik Community Oct 4. Temporary case outage Oct 3. READ DETAILS
cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

Pivot table - not 'fully' pivoting

Hi All,

I think I must be missing something obvious here 😞

I created a pivot, with 2 dimensions and 3 expression (See pic 1):-

Dims = Branch and SGR (Product Subgroup)

Expr = Various stock figures

I am simply trying to get the 2 dims down the left with the 3 expressions across the tops (see pic 2), but every time I have the 2 dims on the left it always drags the expressions to the left also, I cannot get the expressions to the top 'on their own'.

What am I missing please ?

Thanks

BobReport 1.jpgReport 2.jpg

1 Solution

Accepted Solutions
Not applicable
Author

Thanks Miguel & Staffan. I found the problem. I had an old dimension that was no longer available within the report. As soon as I deleted this dimension it worked. A bug I think !

View solution in original post

8 Replies
stabben23
Master
Master

Hi N G, it should be to drag and drop the Expression as you do With the Dimensions. When you see the "blue Arrow" in the top right corner, drop it.

Not applicable
Author

Hi,

If you pivot the stock columns up, it also drags up the SGR column as well - I cannot get it to drag on its own.

😞

stabben23
Master
Master

Place Your cursor here (yellow) and drag it.

drag_drop.PNG

Not applicable
Author

HI,

We do still want Branch and SGR on the left. just the 3 stock columns at the top.

So moving the SGR does not achieve this unfortunately 😞

stabben23
Master
Master

But SGR should not be moved? I'm do not understand, I have simulate Your problem, but for me it Works all the time to move the Expressions, I use QV12

miguelbraga
Specialist III
Specialist III

Hi there,

Please check if you have unchecked this flag in the Pivot Table chart Properties:

Hope this solve your problem

Regards,

MB

Not applicable
Author

Thanks Miguel & Staffan. I found the problem. I had an old dimension that was no longer available within the report. As soon as I deleted this dimension it worked. A bug I think !

View solution in original post

rob_greene
Contributor III
Contributor III

Thank you for this message, saved me hours today.
Hundreds of Dims & Expressions in a pivot, all with conditional shows, colouring etc.  
I'd removed a small table, requested (not a mistake), but the dims were now missing. 

Couldn't remember this.