Qlik Community

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
Customer & Partners, DEC. 9, 11 AM ET: Qlik Product & Strategy Roadmap Session: Data Analytics REGISTER NOW
cancel
Showing results for 
Search instead for 
Did you mean: 
assafmilman
Contributor III
Contributor III

QV server - issue with Email and TLS

Hi all,

I want QVS to send me Email when QVW reload fails. For this I tried to configure the SMTP settings our company uses.
We're using TLS, thus the port is 587. I entered the correct creds and hostname, as it works in another application I'm using.

The error I'm getting is:

The SMTP server requires a secure connection or the client was not authenticated. The server response was: Authentication required


Is this a TLS issue? Any workaround for this?

Thanks,

Assaf

QV_email.PNG

5 Replies
fkeuroglian
Partner
Partner

Hi, works in another application?

the user have got permision to send email through this smtp server?

check that

assafmilman
Contributor III
Contributor III
Author

The same smtp configuration works in Nprinting - I can send Emails via Nprinting without any problem. The only difference I see is that Nprinting has the TLS checkbox.

assafmilman
Contributor III
Contributor III
Author

Anyone familiar with this issue?

ashfaq_haseeb

Hi,

Can you try by changing authentication method to anonymous.

Regards

ASHFAQ

kalyandg
Partner
Partner

Hi,

Go to ProgramFiles, (C:\Program Files\QlikView\Management Service), there find QVManagementService.exe config file(XML).

Open Notepad as Administrator, then open the above said config file, check for the below

  <!-- ****** SNMP ****** -->

    <!-- Set to true to enable SNMP listener -->

    <add key="EnableSNMP" value="false"/>

    <!-- Port to use for SNMP -->

    <add key="SNMPPort" value="4781"/>

    <!-- Set to true to enable secure SSL connection to SMTP server. -->

    <add key="UseSSLForSMTP" value="true"/> --- in default it is set as false, u need to change it to true

    <!-- The textual identification of the contact person for this managed node, together with information on how to contact this person. If no contact information is known, the value is the zero-length string. -->

    <add key="SNMPsysContact" value="Unspecified System contact"/>

    <!-- An administratively-assigned name for this managed node.  By convention, this is the node's fully-qualified domain name. If the name is unknown, the value is the zero-length string. If left empty, it defaults to current machine name -->

    <add key="SNMPsysName" value="Unspecified name"/>

    <!-- The physical location of this node (e.g., 'telephone closet, 3rd floor'). If the location is unknown, the value is the zero-length string. -->

    <add key="SNMPsysLocation" value="Unspecified location"/>

then save the file, restart all  QV services and check for the mail sending option.

Best Regards,

Kalyan