Qlik Community

Ask a Question

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

QlikView forum consolidation is complete. Labels are now required. LEARN ABOUT LABELS
Showing results for 
Search instead for 
Did you mean: 

Qlikview WebServer Service Stopping Automatically

Hi Everyone,

I am facing some issues with Qlikview Services. Qlikview Webserver Service is automatically Stopping from last Friday.

Earlier When I Checked the Event Viewer/Windows Log/ System, I came across the following error:

  • Logon failure: the user has not been granted the requested logon type at this computer.
  • Service: QlikviewServer
  • Domain and account: .\administrator
  • This service account does not have the required user right "Log on as a service."
  • User Action
  • Assign "Log on as a service" to the service account on this computer. You can use Local Security Settings (Secpol.msc) to do this. If this computer is a node in a cluster, check that this user right is assigned to the Cluster service account on all nodes in the cluster.


When I checked the  logs today and tried to find out the error or reason of this in Event Viewer/Windows log/ Application, I came across a different error:

  1. System.Exception: Failed to retrieve document list from the specified QVS || at QMSBackendCore.Service.ServiceImpl.<>c__DisplayClass290_0.<GetUserDocumentList>b__0() || at SolutionGlobal.Collections.ThreadSafeCache`2.CacheItem`1.GetObject() || at SolutionGlobal.Collections.ThreadSafeCache`2.Get(TKey key, Func`1 createObjectFunc) || at QMSBackendCore.Service.ServiceImpl.GetUserDocumentList(Guid qvsID) || at QMSBackendCore.Service.ServiceImpl.Diagnostics.CacheDocumentAvailable() 
  2. Fail Connect to: vcl-srv-qlikbi Error: No connection could be made because  the Target Machine has actively refused it

I tried to find the reason why this error is coming but I am not able to. Please help me with this.

5 Replies
MVP & Luminary
MVP & Luminary

I'm definitely not an expert by administration issues on the Qlik services but if a restart of the whole server didn't help I think it will be caused from any new / changed security setting (group policies, anti-virus, proxy server and similar stuff) which now blocked the communication between the Qlik services and/or to the OS.

- Marcus



You mention two errors are you still seeing the first error : "This service account does not have the required user right "Log on as a service."

If so have you checked the account running the QlikView services has the "Log on as a service" rights? (in your case looks to be the local Administrator user: ./Administrator)

Please check the article on our knowledge base to check this:

How to add "Log on as a service" permissions



Hope this helps!

Please, remember to "like" the post and mark the thread as solved once getting the correct answer



Thanks for the reply. I will surely check the following settings.



Support (Former)
Support (Former)

Regarding the secondary error, that is telling us the service is not able to communicate with the QlikView Server service, and this is likely due to TCP port 4747 being blocked between the web server and the QlikView Server, this would make more sense as to things working and then stopping as a security change in the overall environment may have done something here to block things.  I am assuming you got things sorted, but I wanted to comment on this aspect for folks looking at the post in the future.

One easy test in this case is on the web server, use the Windows Telnet client via a CMD dialog to run Telnet QvServerName 4747, if you get any error, the port is blocked etc., but if the dialog clears and returns a blinking cursor in the upper left corner, that tells us the port is open.  Oh, the Telnet Client is most often not enabled by default in server OS, it is in the Features area of the Windows Server Manager.


To help users find verified answers, please do not forget to use the "Accept as Solution" button on any post(s) that helped you resolve your problem or question.
I now work a compressed schedule, Tuesday, Wednesday and Thursday, so those will be the days I will reply to any follow-up posts.