Qlik Community

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
Customer & Partners, DEC. 9, 11 AM ET: Qlik Product & Strategy Roadmap Session: Data Analytics REGISTER NOW
cancel
Showing results for 
Search instead for 
Did you mean: 
mazman65
Contributor III
Contributor III

STORE help

I am trying to do a simple store to an existing QVD, but am getting a "general Script Error".

Here is the script:

SET ThousandSep=',';

SET DecimalSep='.';

SET MoneyThousandSep=',';

SET MoneyDecimalSep='.';

SET MoneyFormat='$#,##0.00;($#,##0.00)';

SET TimeFormat='h:mm:ss TT';

SET DateFormat='M/D/YYYY';

SET TimestampFormat='M/D/YYYY h:mm:ss[.fff] TT';

SET MonthNames='Jan;Feb;Mar;Apr;May;Jun;Jul;Aug;Sep;Oct;Nov;Dec';

SET DayNames='Mon;Tue;Wed;Thu;Fri;Sat;Sun';

Lockbox2:

LOAD DATE,

     DIFFERENCE,

     [Reconcilation Time],

     maxdate

FROM

[..\Data\Close Improvement\Dashbaord\MEC Snapshot\Data\Bank_Lockbox2.xlsx]

(ooxml, embedded labels, table is [Sheet1 (2)]);

Store Lockbox2 INTO ;

Logfile Error:

STORE Lockbox INTO [E:\Data\Close Improvement\Dashbaord\MEC Snapshot\QVD\Lockbox.QVD

General Script Error

Execution Failed

Execution finished.

1 Solution

Accepted Solutions
danieloberbilli
Specialist II
Specialist II

you need a (qvd) at the end:

Store Lockbox2 INTO (qvd);

View solution in original post

10 Replies
danieloberbilli
Specialist II
Specialist II

you need a (qvd) at the end:

Store Lockbox2 INTO (qvd);

View solution in original post

simospa
Partner
Partner

Hi, I tried with relative path and it works, even without (qvd).

To have your same issue I try to use E:\ to store (and I haven't E:\ unit in my disk).

So I think you'd better to check your path. Try to use another path and let us know.

S.

PS: another curious thing is that you are defining a Lockbox2 and in the log I see you are storing Lockbox, but I think it is a copy/paste misprint.

mohammadkhatimi
Partner
Partner

Store Lockbox2 INTO E:\Data\Close Improvement\Dashbaord\MEC Snapshot\QVD\Lockbox.QVD (qvd);


Remove bracket  from the path or do give properly path by copying from title bar.



Try this.


Regards,


Mohammad

buzzy996
Master II
Master II

the best way is,

define ur path with varibale like below,

SET QVDPath ="D:\XXXXX";

and use that varible "QVDPath " in store command,like below.

STORE URTABLENAME INTO [$(QVDPath)\XXX_QUALITY.qvd];

qlikviewwizard
Master II
Master II

Hi Use this,

Path='E:\Data\Close Improvement\Dashbaord\MEC Snapshot\QVD\'

Lockbox2:

LOAD DATE,

    DIFFERENCE,

    [Reconcilation Time],

    maxdate

FROM

[..\Data\Close Improvement\Dashbaord\MEC Snapshot\Data\Bank_Lockbox2.xlsx]

(ooxml, embedded labels, table is [Sheet1 (2)]);

Store Lockbox2 INTO [$(Path)Lockbox.QVD];

jonathandienst
Partner
Partner

Its possible that the file is locked. You can test that by attempting to change the file name (assuming you have write access).

This is usually caused by multiple processes attempting to write to the file, or a failed process that retained a lock on the file. Look for qv.exe (desktop) and qvb.exe (server/publisher batch reload) processes in the task manager. If you know that a process has failed, then you can kill it  from the teak manager.

Logic will get you from a to b. Imagination will take you everywhere. - A Einstein
mazman65
Contributor III
Contributor III
Author

Thank you for the help!

I was able to get it working with setting a few variables:

SET QVDFILE=E:\Data\Close Improvement\Dashbaord\MEC Snapshot\QVD\Bank.qvd;

LET datatable='Bank'; 


STORE $(datatable) INTO $(QVDFILE);

petter
Partner
Partner

You still HAVE to supply (QVD) at the end of the STORE statement before the semicolon - or you will get a text file not a QVD. It doesn't matter that your name your file .qvd....

It has been pointed out by others in earlier posts on this thread... But judging by your last post you haven't noticed...

mazman65
Contributor III
Contributor III
Author

Thank you Peter!

I have added to the STORE statement

STORE $(datatable) INTO $(QVDFILE)(qvd);