Qlik Community

Ask a Question

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
Our next Qlik Insider session will cover new key capabilities. Join us August 11th REGISTER TODAY
cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

Server 2012 R2 data reload problem through Task scheduler

Hi all,

I've apparently same exact problem as ShaneMichelon had here:

Server 2012 R2 Desktop reload problem

Scheduled task appears hung on running, with 0x41301 Windows state ID.

I'm seeing many other threads with same issue on Windows Server scheduled task, but in my case Qlik 11 engine doesn't update the log file (i.e. refreshing "data.qvw" file I don't have "data.qvw.log" file updated/regenerated). If I run it manually from Task Scheduler while I'm logged in everything's fine.

As Shane suggested, I've modified Settings.ini file in Default folder so that it contains also the elements from the same file located in user folder, but with no success.

Thanks, best regards.

--

Marco Pikiri

1 Solution

Accepted Solutions
Not applicable
Author

Hi Marco,

In case, someone finds this thread.

1) A colleague found an option that should be set on the Qlikview scheduled task, on Windows 2012:

  1. click the Conditions tab.
  2. Check the Wake the computer to run this task check box.

2) Always insert a valid path in the "Start in" option of the scheduled task, even if you don't need it. The task owner should have write permission on it.

3) Also, this thread Re: Server 2012 R2 Desktop reload problem gives another solution. I could make my scheduled task run by copying the whole C:\Users\<myuser>\Appdata\Roaming\Qlikview directory into the Default\AppData\Roaming directory.

4) copy the Qlikview licensed user AppData\Local\QlikTech directory into the Default corresponding directory.


5) Create C:\Users\Default\Documents\QlikTech\QlikView and add write permissions for your Qlikview user.

View solution in original post

6 Replies
Not applicable
Author

Welcome in the same boat. 😕

I have the same problem. My findings are the following:

The scheduled task is executed by a user who uses Qlikview interactively i.e. he opens QV and work on it. The license is installed for this user.


When the user is not logged in the server, QV is started but it does nothing. It doesn't update the data.qvw file and does not generate a log.

The taskmanager displays qv.exe but it takes no CPU (usage=00) and a small amount of RAM (a few Mbytes only).

The scheduled task is frozen in this state.

As we don't have a log, we are left blind 😞

Note: playing with all task scheduler option "run with maximum privileges", "run even if user didn't open a session" ...etc changes nothing at all.

Now the strange part:

If I open a RDS session with the licensed user and leave it alone (I don't use it) and I execute the scheduled task on the Console session (i.e. not from the RDS session), it runs perfectly. Process "qv.exe" uses CPU and RAM. A process "qvconnect32.exe" and QVW files are generated.


I suspect the fact that QV opens the "Script Execution Progress" window to display the reloading status is the blocking factor here. Windows 2012 may block the process because the scheduled task runs inside a non-interactive mode where the GUI cannot be opened.


I asked to the Qlik support who replied "it's not a problem in Qlikview. Please ask the community."

This is a bad answer as the above tests are 100% reproducible and shows perfectly the scheduled task is correctly created. There is some interaction between the fact that QV displays a GUI and how scheduled tasks are executed in Windows 2012.

I wish there was a "/nogui" command line argument for QV 🙂

Not applicable
Author

Hi Philippe,

I apologize for delay, I've totally forgotten to close this post.

Some weeks ago (i.e. some months after my request), I've solved by myself following this procedure:

1) Open the Windows group policy editor (Start --> Run --> gpedit.msc).

2) Go under Computer Configuration --> Administrative Templates --> System --> UserProfiles.

3) Search for "Do not forcefully unload the user registry at user logoff" setting: change it from “Not Configured” to “Enabled”.


Hope this could help you too.


Regards.

--

Marco Pikiri


Not applicable
Author

Hi,

Thanks for the hint.

It does not seem to have any effect here but I'll keep on trying.

Thanks.

Not applicable
Author

Hi Marco,

In case, someone finds this thread.

1) A colleague found an option that should be set on the Qlikview scheduled task, on Windows 2012:

  1. click the Conditions tab.
  2. Check the Wake the computer to run this task check box.

2) Always insert a valid path in the "Start in" option of the scheduled task, even if you don't need it. The task owner should have write permission on it.

3) Also, this thread Re: Server 2012 R2 Desktop reload problem gives another solution. I could make my scheduled task run by copying the whole C:\Users\<myuser>\Appdata\Roaming\Qlikview directory into the Default\AppData\Roaming directory.

4) copy the Qlikview licensed user AppData\Local\QlikTech directory into the Default corresponding directory.


5) Create C:\Users\Default\Documents\QlikTech\QlikView and add write permissions for your Qlikview user.

View solution in original post

Not applicable
Author

In my case I solved using the method I wrote on december 22nd.

I should point out that at present I am not able to verify your solution, but no problem to mark your solution as the helpful one.

Best regards.

--

Marco Pikiri

canoebi99
Partner
Partner

Thanks so much for this Philippe ... I had been tearing my hair out on this one ..... for the benefit of others we had several tasks set up and most were working fine when the user was logged off. Two however were not. The two that were hanging as described above were both reloading documents via a unc path (all the working ones were loading documents local to the server). Selecting the option to wake the computer as suggested has resolved both of these now and they both now run fine when the user is logged off. Thanks Again!