Qlik Community

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

Sheet Level Security - Conditional Show

I am using NT security for Section Access and need to set up a conditional show expression to only show the "Details" sheet if "LEVEL" = "DETAIL".

See my section access code below:

Section Access;

LOAD * INLINE [

    ACCESS, NTNAME, LEVEL

    USER, iwavetwo\jrush, DETAIL

    USER, iwavetwo\dstein,

    ADMIN, iwavetwo\bash, DETAIL

];

Section Application;

Does anyone know how to make this happen?

1 Solution

Accepted Solutions
Not applicable
Author

Yigal BO wrote:

Hi,

Try This:

SECTION ACCESS;

LOAD * INLINE [

    ACCESS, USERID, LEVEL

    USER, 1, DETAIL

    USER, 2,NO_DETAIL

    ADMIN, 3, DETAIL

];

Section Application;

LOAD * INLINE [

    LEVEL,VALID

    DETAIL, 1

    NO_DETAIL,0

];

And then in the Conditional Show:  sum(VALID)>0

See the attach example.

Hope it help.

Thanks for your reply, Yigal BO.

This is the correct approach, but I found out it does not work until you turn on the check box, "Initial Data Reduction using Section Access."  It worked for me after checking that box.  Also, I turned Strict Exclusion on.

View solution in original post

3 Replies
Not applicable
Author

Hi,

Try This:

SECTION ACCESS;

LOAD * INLINE [

    ACCESS, USERID, LEVEL

    USER, 1, DETAIL

    USER, 2,NO_DETAIL

    ADMIN, 3, DETAIL

];

Section Application;

LOAD * INLINE [

    LEVEL,VALID

    DETAIL, 1

    NO_DETAIL,0

];

And then in the Conditional Show:  sum(VALID)>0

See the attach example.

Hope it help.

Not applicable
Author

Yigal BO wrote:

Hi,

Try This:

SECTION ACCESS;

LOAD * INLINE [

    ACCESS, USERID, LEVEL

    USER, 1, DETAIL

    USER, 2,NO_DETAIL

    ADMIN, 3, DETAIL

];

Section Application;

LOAD * INLINE [

    LEVEL,VALID

    DETAIL, 1

    NO_DETAIL,0

];

And then in the Conditional Show:  sum(VALID)>0

See the attach example.

Hope it help.

Thanks for your reply, Yigal BO.

This is the correct approach, but I found out it does not work until you turn on the check box, "Initial Data Reduction using Section Access."  It worked for me after checking that box.  Also, I turned Strict Exclusion on.

Not applicable
Author

Hi brandoncash,

If i have less than 10 user it is fine.

suppose i have 1000 users, then what will we do...

Thanks.........