Qlik Community

Ask a Question

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
Become an analytics expert with Qlik's new 15 week course: Applied Data Analytics using Qlik Sense. READ MORE
cancel
Showing results for 
Search instead for 
Did you mean: 
chaiperi
Creator III
Creator III

Sheet level Section access issue with NTNAME works on Desktop but not in Access Point

I am trying to implement Sheet level section access based on NTNAME(upper case) as below.I have conditions  as if(Sheet1=1,1,0) and if(Sheet2=1,1,0) on both sheets.It works great in desktop.But when it is published to Server , I can see the application but if I try to open it say "failed to open or don't have to access".I don't know may be the NTNAME on AccessPoint in lower case compared to on desktop?Need help to fix this. swuehlhic marcus_sommer

jagan‌   Thanks

Capture.PNG

Section Access;

LOAD ACCESS,

         NTNAME

FROM Table QlikSection Access;

Section application;

[Sheet Level]:

LOAD

     NTNAME,

     SHEET1,

     SHEET2;

FROM Table QlikSection Access;

1 Solution

Accepted Solutions
swuehl
MVP
MVP

Don't use NTNAME as reduction field.

This will limit the reduction field to the user that does the reload & save.

Use a distinct field for reduction (you know, don't forget upper case) and use star symbol in that field for the service user.

Something like

Section Access;

LOAD ACCESS,

         NTNAME,

         SHEETACCESS

FROM Table QlikSection Access;

Section application;

[Sheet Level]:

LOAD

     SHEETACCESS,

     SHEET1,

     SHEET2

FROM Table QlikSection Access;


with a table


SHEETACCESS, SHEET1, SHEET2

A, 1,1

B, 0,1


and a SA table

ACCESS, NTNAME, SHEETACCESS

ADMIN, SERVICEUSER, *

ADMIN, USERA, A

USER, USERB, B


View solution in original post

26 Replies
stabben23
Master
Master

Hi,

if you are unsure about the ntmane add keyword Upper

Section Access;

LOAD ACCESS,

        upper(NTNAME ) as NTNAME

 

FROM Table QlikSection Access1;

Section application;

[Sheet Level]:

LOAD 

     upper(NTNAME) as NTNAME,

     Sheet1,

     Sheet2;

    

FROM Table QlikSection Access1;

You also need the service account added in the accesslist.

chaiperi
Creator III
Creator III
Author

Thanks for reply .No luck even after using Upper.Still can't access app on AcceePoint

marcus_sommer
MVP & Luminary
MVP & Luminary

For testing disable the section access and use a textbox with: = osuser() to check that the osuser from the desktop client is the same as within the access point.

- Marcus

chaiperi
Creator III
Creator III
Author

Thanks for reply.I did checked OSUser() on server without section access.It is in upper case and matches with NTNAME of my Section Access table.Service account is also in section access.As I am doing section access for sheets not data Do you think I am using right approach to show hide sheets?Do I have to pick selection based on Section Access option?

Capture.PNG

marcus_sommer
MVP & Luminary
MVP & Luminary

Is there any sheet within the application which is not included within the section access, for example SHEET3? For testings there should be at least one sheet without restrictions. Another try would be to use another browser - maybe the browser didn't transfer the osuser to the qlikview-server.

- Marcus

chaiperi
Creator III
Creator III
Author

I added another sheet to show all the time.I did checked both IE and Chrome still getting same error as below.

Thanks

Access issue.PNG

Peter_Cammaert

You're doing the right thing by enabling Data Reduction and checking the Strinct Exclusion checkbox. Otherwise it would never work.

If it works in QV Desktop, but doesn't work in the AccessPoint, you may be using an Admin account that hasn't got a single actual entry in table [Sheet Level]. Keep in mind that an ADMIN role will always grant you access to your document in QV Desktop (even with Strict Exclusion enabled) but will kick you out of your document in the AP because Admin doesn't exist in the AccessPoint.

Make a file copy of your document, open it in QV Desktop, change the SA table to list your account as a USER, enable Section Access, reload and save. Close QV Desktop. Now reopen your document in QV Desktop. Does it still work?

krishnacbe
Partner
Partner

Hi,

Can you Uncheck the "Strict Exclusion" check box and reload and publish to access point and check.

Section_Access.png

stabben23
Master
Master

If you change to this in Your sheet condition.

sum(if(upper(OSUser())=NTNAME,SHEET1))