Qlik Community

Ask a Question

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
May 18th 10AM ET, Live Chat, bring your QlikView questions. REGISTER
cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

Unable to use teradata functions


Hello everyone,

I have just moved from one server to another.

I use an ODBC connection to connect to a teradata database.

On my new server, I get an error each time I use an SQL teradata function in the script.

For example, in my sql statetement, if I do SELECT Somedate, ...   it works

But If I do SELECT DATE(Somedate) or MONTH (Somedate), I get the error " Syntax error : Data Type "Somedate" does not a Defined Type name."

Maybe it comes from the ODBC configuration ?


Or do I have to configure something in QV ?

As I said, the application worked on my previous server..


Thank you for your help

Laura

2 Replies
nagaiank
Specialist III
Specialist III

If the Teradata functions are in a SQL statement, did you use the SQL prefix?

SQL  (valid SQL SELECT statement with Teradata SQL functions)

Not applicable
Author

I did.

As I said, the application worked on my previous server