Qlik Community

Ask a Question

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

QlikView forum consolidation is complete. Labels are now required. LEARN ABOUT LABELS
Showing results for 
Search instead for 
Did you mean: 
Not applicable

[V11.2 SR4] Bug with ODBC Connection to .accdb or .mdb

Hi everyone,

Don't know if it's a known bug ...

With 11.2 SR4, when I use an ODBC connection to .accdb all fields begins and ends with the character ` .

Example :

LOAD `Product_ID`,




FROM Articles;

And when I reload I have the error : 'Field not found'.

If I replace all characters ` with nothing the reload works well.

Any idea how to fix this ?



6 Replies
Contributor III
Contributor III

We have this same issue Benoit. I called Qliktech and awaiting their response. All tasks were working previous. Now any reload tasks fail...but distributing still works...

Tried the firewall shutoff option still didnt fix.

We also upgraded the desktop developer version and get the same problem. had to revert to get it working again.

I'll keep you posted if you keep me posted!

Contributor III
Contributor III

Benoit here is our solution from a smart guy that helped us out on another posting:

Make sure you are not using this character in your field names for your loading scrip: ` Accent Grave (beside 1 on keyboard US version)


Bill Britt (to Jareb Patriquin) 46 minutes ago


Are you using Grave Accent ` (hard to see) in your script?  If so you need to change them to [ ] or "


Reply • Like Show 0 Likes(0)

Jareb Patriquin

Jareb Patriquin (to Bill Britt) 1 minute ago

This has resolved our issues. All our main scripts have some of our original script that contains these characters! I am changing them and the tasks are now reloading. THANK YOU!

PS Still waiting to hear from Qliktech after all the log files I sent. I should let them know the issue has been resolved.

Thanks Bill!

Not applicable


This solution is useful but we will need to change the characters each time we add a table with the 'Select ..' button.

Is it any way to delete the Grave Accent when using this driver unless having to change it manually ?



Specialist III
Specialist III

For .accdb you always use OLE DB Connection .

This may help you.

Contributor III
Contributor III

In our case if loading from QVD tables there shouldn't be any of those Accents.

If you have script that contains it, then you can do a find: ` and replace all on all tabs with: ". -worked for all my scripts.

Also there is a patch for this problem, and this bug will be fixed in SR5 per Qlikview support.


Not applicable

Thanks to Jareb and Bill.

I will use the 'replace all' solution until the SR5 is available.

Anyone knows the reason of the grave accent ?

With a connection to SQL Server or Oracle Database I will have [ ] .