Skip to main content
Announcements
July 15, NEW Customer Portal: Initial launch will improve how you submit Support Cases. IMPORTANT DETAILS
cancel
Showing results for 
Search instead for 
Did you mean: 
Anonymous
Not applicable

Variable in sheet trigger not working

Hello everyone,

I have an application with three sheets, two for analysis and one with the selections management.

I hide the tabrow and navigate in my application with buttons. When I go on an analysis page, I have a trigger OnActivateSheet which takes the sheet ID and set it into a variable:

Capture.PNG.png

Then, if I go on the selections management page and come back to the analysis page like this:

Capture.PNG.png

It works fine with IE plugin but when I use another web browser like Google Chrome, it doesn't work.

How can I fix this ?

Thanks,

Quentin

1 Solution

Accepted Solutions
datanibbler
Champion
Champion

Hi,

this is a QlikView bug. We were trying to do the same, an external consultant told us this simply does not work in browser_view.

We circumvented it by putting the triggers on the navigation_buttons instead.

HTH

Best regards,

DataNibbler

View solution in original post

3 Replies
datanibbler
Champion
Champion

Hi,

this is a QlikView bug. We were trying to do the same, an external consultant told us this simply does not work in browser_view.

We circumvented it by putting the triggers on the navigation_buttons instead.

HTH

Best regards,

DataNibbler

jerrysvensson
Partner - Specialist II
Partner - Specialist II

If you look in the reference manual you will find that OnActivateSheet trigger doesn't work in Ajax (browser_view).

Use DataNibblers solution.

Anonymous
Not applicable
Author

Thanks guys for your fast answers.

DataNibbler, your solution is working fine. Thank you