Qlik Community

Ask a Question

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
QlikView forum consolidation is complete. Labels are now required. LEARN ABOUT LABELS
cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

x-mark on buttons

Hello,

When I open a qvw file, sometimes x-mark appers on buttons. (like below)

The buttons became nomal after I reload sevral times.

I supporse slow button drawing may cause the problem, but is there something I can do to avoid it?

7 Replies
jagan
MVP & Luminary
MVP & Luminary

Hi,

Only for buttons you are getting like this or for other chart objects too?  If it is only for buttons then recreate the buttons and check.

Regards,

Jagan.

amit_saini
Master III
Master III

Hi Naho,

Looks like your buttons has crashed, I will suggest you to create them again.

Thanks,

AS

Not applicable

Thank you, amit

I already tried to recreate the buttons but I still have the same plobrem.

Not applicable

Thank you, Jagan

I think I've sawn my pivot table get like this before, but not remember well,

I already tried to recreate buttons but it doesn't work.

jagan
MVP & Luminary
MVP & Luminary

Hi,

If you are having tables or charts with Aggr() expressions then you will get like this.  If you are using tables then select any filters which results in loading less records.  For now just use only buttons in the sheet and test whether buttons are loading, if it is loading successfully then restrict the users for selecting the filters to load the Tables.

Regards,

jagan.

Not applicable

Thank you again,

Actually, there's only some buttons on the sheet so I don't know if Aggr() expressions have something to do with this problem or not.

The sheet these buttons are on is a menu and I can jump to 2nd sheet which has some charts by clicking them.

the charts on 2nd sheet deal huge data, contain Aggr() expressions, so I think it influence the buttons on the menu sheet.

But still I don't know how to fix it.

qlikpahadi07
Specialist
Specialist

Dear Naho,

these lines are just calculation time taken by Qlikview tool when you open the aap.

Depending on the application size/calculation logics/ objects your machine should be capable to loading all in seconds.

if you have better machine configuration check on that machine or let me know the configuration of your machine and application size.

you can check in your task manager how much RAM is getting consumed when you open your Qlikview App.

cheers!!!!