Qlik Community

QlikView Connectivity

Discussion board for collaboration related to QlikView Connectors.

Announcements
Join “Do More With Qlik” with Mike Tarallo to get a first-hand look at the New Authoring Experience, June 29th: REGISTER HERE
cancel
Showing results for 
Search instead for 
Did you mean: 
pascal_theurot
Partner
Partner

Sap infoprovider connector fetch 0 rows

Sap infoprovider connector V 7.0.0 and QS September 2018 SR1 (12.36) and QlikView Desktop november 2017 SR7.

I can’t retrieve values from a multiprovider (MPRO) which always fetch 0 records.

This multicube contains 27.5 millions rows and 200 dimensions/110 measures. So a quite heavy one...

The connector works fine with another multicube with less rows, dimensions and measures.

Works fine too using BEX requests from qlik connector.

I’ve tried to change the advanced properties :

  • Packetsize = 5000 instead of 20000
  • BufferPercentage = 999 and 30
  • Timeoutfetch and timeoutbatch = 36000

I’ve tried too with only 1 dimension with or without a multiple “where” clause (reducing until 1 row).


Each time, I fectch 0 rows

The log file on Qlik Side looks ok :

25 Oct 2018 14:30:34,878 [5] - INFO - SAPInfoProviderConnection.GetSAPData() - Fetch completed successfullly, received all 0 rows sent from SAP.

25 Oct 2018 14:30:34,878 [5] - INFO - SAPInfoProviderConnection.GetSAPData() - Finished, took 00:00:00.3824298.

And the log on the sap side :

logsap.png

After lauching a first connexion, the time is very short to render 0 row message.

So questions :

  • Is there a cache on BW side as the connector give a response with 0 rows very fast without any errors ? If yes, is there a way to remove it ?
  • Is there a parameter that I should try in order to fetch a least some rows to investigate further ? For now, I’ve never retrieved any values from this multicube.
Pascal
6 Replies
Hakan_Ronningberg

Hi Pascal,

Check the job log in the SAP transaction SM37 for your  SAP job name.

You can use the connection string property MAXROWS to fetch some rows. For example MAXROWS=100 will fetch 100 rows.

Regards,

Hakan

mats_olin
Employee
Employee

Does it work to extract data from the MP if you try to do it in transaction LISTCUBE in BW? / Mats

pascal_theurot
Partner
Partner
Author

Hello Mats,

thx for your reply.

I get the following anwser with LISTCUBE transaction :

message in French = 'too many characters. Apply a preselection'

Not sure how to handle it in qlik script as using "WHERE" in the sql doesn't change the behaviour.

listcube.png

Pascal
pascal_theurot
Partner
Partner
Author

Hi Hakan,

thx for your reply.

Unfortunately, limiting the number of rows and reducing the packet size, doesn't change the result.

Using SM37 transaction, I get the following message :

The field string "LT_GENTAB" contains no fields. 4 LT_GENTAB

and then "job aborted".

It seems that the "internal table" created has too many fields even if I select only 1 characteristic in my request (with or without the were restriction= :

SELECT

[0MATERIAL]

FROM ZSD_MC01

WHERE (

    WSIGMONTH = 201809

)

Pascal
mats_olin
Employee
Employee

Can you in LISTCUBE click accept on that message and in the next screen select just one Characteristic (like 0MATERIAL) and then run the extraction and see if that works? If you can't get any data in LISTCUBE your issue is likely in SAP, then search for SAP Notes for the error message you might receive. If you get a result set in LISTCUBE, please register a support case with Qlik referring to this thread and we can look further into your issue/ Mats  

pascal_theurot
Partner
Partner
Author

Thx Mats

it works with 1 Characteristic.

I'll open a case.

Pascal