Qlik Community

QlikView Connectors

mike_garcia
Contributor III

Increase Package Size - SAP

Hello,

I'm pulling data via SAP Connector at a Rate of 5,000 record per second. I know there is a parameter to be placed in the connection String (Packetsize) to increase the number of records fetched per second. But when I set the parameter, apparently QV is ignoring it, since the packet size does not change.

If I set it to 20,000, it stays at 5,000. If I set it to 200, it is still 5,000. Am I doing something wrong regarding syntax?

This is how the string looks like:

CUSTOMCONNECT TO "Provider=QvSAPConnector;ASHOST=*************;SYSNR=**;CLIENT=***;XUserId=someuser;XPassword=somepassword;Packetsize=20000;";


Can someone help?

Also, when I load data from another set of tables, it goes down to 2,500 rows per second. What is causing it to drop?

Thanks in advance.

Tags (1)
4 Replies
mike_garcia
Contributor III

Increase Package Size - SAP

Ideas please, anyone?

disqr_rm
Valued Contributor III

Increase Package Size - SAP

Well, if you hange the connection parameters and nothing changes, I would recommend you contact the QlikTech support. Ideally the connection parameters should set the attributes in SAP to download the data.

lwt
Contributor III

Increase Package Size - SAP

Hi,

the packetsize parameter is an upper limit, to make sure the Connector doesn't use too much memory. At runtime the Connector calculates how much memory is avaliable and in many cases adjust the memory used downwards. In reality it does not affect the speed very much unless set too very low number.

Regards,

Lars Wahlstedt

suniljain
Honored Contributor

Increase Package Size - SAP

Dear Mike,

I have same types of problem . if change MaxRows Prperty it does not change accordingly.

Example :

ODSMaxRows=200000000;



Community Browser