Qlik Community

Ask a Question

QlikView Creating Analytics

Discussion Board for collaboration related to Creating Analytics for QlikView.

Announcements
Qlik Highlights 2020 Giveaway! Watch, reply and have a chance to win a $200 Amazon Gift Card! Watch Video
cancel
Showing results for 
Search instead for 
Did you mean: 
Contributor II
Contributor II

Unnable to import excel data due to image object

Hello,

I'm am trying to automate a report. Basically it has to read an excel file (.xlsx) and make charts with the data. This excel file is automatically generated by a secondary app wich besides the usable data, inserts (by default) a few rows of creation data along with an image with the company logo.

The problem is that when i try to import the data from the Excel file, with QlikView script file assistant, nothing is read. Preview won't show any data no matter how many header lines i skip. As soon as i tried removing the image manually from the excel file, i was able to import all the data, but manual intervention is what i am trying to avoid in the first place.

I've read some posts and it seems that you can treat the image as an object, i believe this shoud allow me to somehow grab it and delete it before trying to read the data. 

I would appreciate any ideas or help with this problem.

Screenshot attached showing file assistant not loading data.

1 Solution

Accepted Solutions
Contributor II
Contributor II

Hello Marcus,

Indeed it works with this file, i had not tried importing an edited file without removing the image.

I just tried editing a single line (not the image) on a fresh file and then saving it... it works.

Then i tried saving a fresh file without changing anything and it worked as well.

So it might have to do with the way the data is inserted into the file, like Ruben said.

View solution in original post

4 Replies

Hi Matias,

Hard to say withut the excel to make test, can you upload a dummy excel with the logo (or another image to simulate it) and with some dummy data?

I've loaded excels with logos so it has to be somethig with this particular excel and how the logo/data is inserted

 

 

Contributor II
Contributor II

Hello Ruben,

Thank you for your reply, i have added "Example File" to the post, with the original image and the data format (w/ edited text).

MVP & Luminary
MVP & Luminary

For me it worked like it should - within the file-wizard and also after loading the data:

LOAD column1, column2,  column3
FROM [Example File.xlsx] (ooxml, embedded labels, header is 7 lines, table is [Tabular Reports]);

Just try it again.

- Marcus

Contributor II
Contributor II

Hello Marcus,

Indeed it works with this file, i had not tried importing an edited file without removing the image.

I just tried editing a single line (not the image) on a fresh file and then saving it... it works.

Then i tried saving a fresh file without changing anything and it worked as well.

So it might have to do with the way the data is inserted into the file, like Ruben said.

View solution in original post