Qlik Community

QlikView Deployment

Discussion Board for collaboration related to QlikView Deployment.

peter_turner
Valued Contributor

AJAX error message from IIS - Failed to open document, You don't have access to this document

Hello Everyone,

I get error message "Failed to open document, You don't have access to this document" when i try to load the AJAX pages via IIS.

scenario:
I'm using QV9 on Windows2003 server, 32bit
Running as Admin directly on the server
I want to access my project via AJAX, using a nice short URL such as http:\\server\MYproject


I have used the Objects Client Page Generator to create the AJAX pages
Target folder is c:\myweb
Document URL points to qvp://localhost/MYproject.qvw

In IIS i have created a new website 'MYProject'
Selected the folder c:\myweb (note the ajax pages are within another folder called MYproject_ajax)
Left permissions as Read.
Done.

When i test the website by rightclick, browse, i get the error message.
Also when i navigate to http:\\localhost\MYproject i get the same error.



Does anyone have any suggestions as to what to try?


Thanks,
Peter.

12 Replies
Employee
Employee

AJAX error message from IIS - Failed to open document, You don't have access to this document

This may be caused by the QV server not being able to see the QVW. Is it in the User Document Folder that is set in the server Console?

peter_turner
Valued Contributor

AJAX error message from IIS - Failed to open document, You don't have access to this document

Hello,

The document was in a mounted folder on the server at the time.
I've been in touch with my QV contact and we're looking into the problems with this.

Basically at present i cannot have my generated Ajax pages hosted by IIS for some reason, i have to use the Accesspoint.
When QV get back to me i'll post the findings here Smiley Happy

Peter.

twebber
Contributor II

AJAX error message from IIS - Failed to open document, You don't have access to this document

Did QV get back to you? If they did or you solved your problem please do post here!

peter_turner
Valued Contributor

AJAX error message from IIS - Failed to open document, You don't have access to this document

Hi,

QV did get back to me and it appears to be a bug, this was back with V9 and maybe SR1, i've not tested it with SR2.

The idea was that i could use the normal IIS to host the pages and do away with the QV accesspoint, and also have a simple url to reach the pages, instead of the huge URL that is generated from the accesspoint.
Last i looked awhile ago it was still a bug, but if anyone gets this to work i'd be very interested.

Thanks,
Peter.

gandalfgray
Valued Contributor

SV:Re: AJAX error message from IIS - Failed to open document, You don't have access to this document

Have you been able to make any progress with this yet?

I have the same problem, but are using V9 SR3 build 7440. (64bit)

I have tried both with IIS and QVWS as webserver, but gets the "Failed to open..." message as described above, with any of them

I would also be interested to hear if anyone gets this to work...

twebber
Contributor II

SV:Re: AJAX error message from IIS - Failed to open document, You don't have access to this document

Oops, didn't mean to suggest ^^^ as an answer. Did you follow the steps in the QVS manual to setup for IIS? THere are a number of steps that you need to follow otherwise you will have issue with IIS.

vgutkovsky
Honored Contributor II

AJAX error message from IIS - Failed to open document, You don't have access to this document

If this works with other clients, then the problem is most likely with anonymous authentication. By default, AJAX access is anonymous. So you would need to make sure that you enable anonymous authentication on the QVAJAXZfc virtual directory in IIS. Also make sure that your QVS security settings are not set to prohibit anonymous as this may cause conflict errors. Finally, try adding the IQVS_machinename account (this is the Qlikview anonymous account) with read access in the QVW security.

On the other hand, if this does not work with other clients, you should check to make sure Windows Authentication is enabled in IIS on all virtual directories, and anonymous authentication is enabled on qvajaxzfc and scripts.

Regards,

gandalfgray
Valued Contributor

SV:Re: AJAX error message from IIS - Failed to open document, You don't have access to this document

Thanks Vlad!

I followed your advise first adding "ANONYMOUS LOGON" account with "Read & Execute" and "Read" permissions on the .qvw file.

No progress, still same error message.

I then added "IQVS_machinename" account with "Read & Execute" and "Read" permissions,

and that did something, because I now get the following instead:

so I will go back to my chamber and read the manual for a while...

vgutkovsky
Honored Contributor II

SV:Re: AJAX error message from IIS - Failed to open document, You don't have access to this document

Make sure you have set "Allow Anonymous" in QVS Security Settings. Also, check to make sure your LEF doesn't contain any restrictions on anonymous User CALs.

Regards,