Qlik Community

QlikView Deployment

Discussion Board for collaboration related to QlikView Deployment.

chauhans85
Esteemed Contributor

Ajax view slow in Qlikview 11sr 6 after migration from Qlikview 10 Sr4

Hi,

We have migrated qlikview 10 SR 4 to Qlikview 11 Sr 6. and found that qlikview with IE plugin is working fine (speed). where as in ajax view performance is very slow.even  when i click on list box it showing progress circles.and opening . is there any specific setting needs to do @ server.

we are using windows server 2008 R2 +Qlikview Server 11 SR6

client build number:11.20.12354.0.

we have server and publisher @ two different machines. please let us know if any more info required to help me.

Thanks

Sunil

14 Replies

Re: Ajax view slow in Qlikview 11sr 6 after migration from Qlikview 10 Sr4

Hi,

Heard about the same issue from more then one people here in the community.

Why don't you consider upgrading to sr7.

Regards

ASHFAQ

dirk_konings
Contributor III

Re: Ajax view slow in Qlikview 11sr 6 after migration from Qlikview 10 Sr4

We have the same after an upgrade to 11.20 SR5 with a QVS Cluster and Publisher on other machine.

No good respons from Qlik Support, just "create a better datamodel".

Why? The datamodel was fine in a previous release and we can't make it better due to level of detail and use of large SetAnalysis expressions.

Dirk K.

chauhans85
Esteemed Contributor

Re: Ajax view slow in Qlikview 11sr 6 after migration from Qlikview 10 Sr4

this is working good in IE but not ajax. currentely we have migrated to SR6 and is it good idea to updgrade?

could you please provide some other workaround if any?

chauhans85
Esteemed Contributor

Re: Ajax view slow in Qlikview 11sr 6 after migration from Qlikview 10 Sr4

have you ever fixed issue ?found any solution?

dirk_konings
Contributor III

Re: Ajax view slow in Qlikview 11sr 6 after migration from Qlikview 10 Sr4

We decided to reinstall the IE plugin on the Citrix farm.

You could have a look on your expressions and tha cache of it. It could help the performance on each sheet

http://community.qlik.com/blogs/qlikviewdesignblog/2014/04/14/the-qlikview-cache

gno
Valued Contributor II

Re: Ajax view slow in Qlikview 11sr 6 after migration from Qlikview 10 Sr4

Chauhans,

The document that you are testing, does that document has any document triggers? ( ex. OnOpen,etc) If that the case, that could be the root cause of the issue. To find out if you have document triggers, open document in developer>document settings > triggers > under "Document Event Triggers", if this had something like "<has action>" next to the to each command, that means that it has a action, and depending the one you are using, it will degrade the performance of Ajax. Ajax is a single thread client when Macros or document triggers are involved for that it take very long time to load. In the contrary, IE plug-in is multi-thread which it respond time is faster.

the other possible issue, shared files. A quick test would be renaming the document .SHARED file and try to open the document once again, if the actually help the performance that means that the .SHARED file has corruption for that you might want to clean the SHARED file. In the release note gives instructions how to do so.  look page 46

https://d1cf4w4kkla6tb.cloudfront.net/qlikview/11.20/12354/QlikView%2011.2%20build%2012354%20SR6%20R...

Gio

chauhans85
Esteemed Contributor

Re: Ajax view slow in Qlikview 11sr 6 after migration from Qlikview 10 Sr4

it has no actions

and shared file is also fine. could you please suggest some other workaround if any?

gno
Valued Contributor II

Re: Ajax view slow in Qlikview 11sr 6 after migration from Qlikview 10 Sr4

Dear Chauhans,

Can you tell me how you confirmed that the shared file is fine? Can you just try to re-name the shared file, let QVS create a new one and check if that alleviates the problem. It could also be that the shared files are too larger, larger than 32K of size, which would cause problem as well.

Gio

chauhans85
Esteemed Contributor

Re: Ajax view slow in Qlikview 11sr 6 after migration from Qlikview 10 Sr4

Thanks for reply.

i did this . now my shared file size is of 2 Kb and its took time to open app and also when select in any list box it showing progress circles . see the attached imageprogress bar.bmp

i have also optimized my model . that means i am only loading tables there is no join in application.

i dont know what happening here. could you please suggest 

thanks

Sunil