Qlik Community

QlikView Deployment

Discussion Board for collaboration related to QlikView Deployment.

marwen_garwachi
Contributor II

Problems with licences

Hi,

I have some broblems with Licences and QVW Server :

When I want to show the license page of the Qlikview management console, the internet browser hangs

After a few minutes we see the following page (like we never imported a license LEF file) and the error message at the bottom of the page server is Down (but it isn’t down at all)

(even if we restart the server and look again, same problem)

The problem is not raised after a migration or system or Qlikview change, is possible raised after a windows update, we are not sure

Result is that the server can be accessed externally by our clients, but we can only develop with one specific user instead of 5 users

+ bizar : this only developUser can only be successfully used if you start an rdp session from a specific (other) userprofile

Screen_Shot1.jpg

Figure : licenses are empty and message server is down at the botton

Windows Application Eventviewer shows : System.Exception: Failed to retrieve CAL configuration from QlikView Server    at QMSBackendCore.Service.ServiceImpl.GetCALConfiguration(Guid qvsID, CALConfigurationScope scope

Screen_Shot1.jpg

Figure : Qlikview management console tab about

LEF FILE :

NAMED_CAL_BY_MACHINE_ID;NO;;

NUMBER_OF_SESSIONCALS;1;;

NUMBER_OF_USAGECALS;10;;

NUMBER_OF_USERCALS;5;;

PRODUCTLEVEL;10;;2012-01-01

Anyone can help ?

Thanks in advance

Labels (1)
1 Solution

Accepted Solutions
marwen_garwachi
Contributor II

Re: Problems with licences

Done bu same problem

13 Replies
Not applicable

Re: Problems with licences

Restart all your qlikview services for a start

marwen_garwachi
Contributor II

Re: Problems with licences

Done bu same problem

flo
Contributor

Re: Problems with licences

1.sorry to say this, but it appears that the product level is 2 years old.

I am not sure if this is the issue nevertheless it needs to be verified.

2. you are running 10 SR2 and the green mark is pointing at Publisher license and the lef you pasted is not a publisher lef

3. you can try from the local client;

open qv local client, go to user preferences> locations and choose QlikVIew Management Console, paste in the URL for the QMC and apply and close the user preferences

now go to tools and choose open qlikview management console

4. do you open the QMC on the machine where the QVS is installed? if not could you try that as well

5. if none of the above helped, make sure you get the lef updated, stop the services, if you have internet connection, then just apply the license number and the control number, if not then paste the updated lef before apply.

looking forward to your feedback.

marwen_garwachi
Contributor II

Re: Problems with licences

2. same problem : the management console hangs for 3 minutes and than show a screen without licenses

4. Yes I work with an RDP session in the machine where QVS is installed

5. I cannot write into the inputfields  of the left side (the qlikview server licence fields, but I can write in the inputfields on the rightside the publisher license …)

Thanks for you help so far

flo
Contributor

Re: Problems with licences

ok,

stop all services, rename the qliktech folder under C:\ProgramData and restart the services, this will create a new QlikTech folder. try to apply the license again. do you have the same issue?

fkeuroglian
Honored Contributor

Re: Problems with licences

1)Delete the qlikview server

2) Delete all the folder in c: about qlikview

3) re install qlikview server

when you reinstall , qlikview will create properly all the folder structure

good luck

Fernando

flo
Contributor

Re: Problems with licences

I will suggest a rename instead of just delete. So you can at least roll back if it doesn't work

marwen_garwachi
Contributor II

Re: Problems with licences

I can't Delete the QVS...

I found the problem by checking the logs I find this message error.

I know where the problem is but I don't know how to solve this.

LDAP points to a wrong adress, but I don't have access to QMC so I can not rectify

Any solution ??

Thanks !

9/01/2014 14:27:02.4042430     Warning            (ActiveDirectory.ActiveDirectoryProvider) Fetching directoryentry LDAP://VT.local/RootDSE failed: The server is not operational.

9/01/2014 14:27:02.4042430     Warning            (ActiveDirectory.ActiveDirectoryProvider) Exception while initializing LDAP://VT.local: The server is not operational.

9/01/2014 14:27:02.4354442     Error     (DSC.DirectoryFramework) setup path not successful for user 'g0002' at 'LDAP://VT.local': System.Runtime.InteropServices.COMException (0x8007203A): The server is not operational.

   at System.DirectoryServices.DirectoryEntry.Bind(Boolean throwIfFail)

   at System.DirectoryServices.DirectoryEntry.Bind()

   at System.DirectoryServices.DirectoryEntry.get_NativeObject()

   at ActiveDirectory.ActiveDirectoryProvider.GetDirectoryEntry(String _path)

   at ActiveDirectory.ActiveDirectoryProvider.SetupPath(String _path, String _username, String _password)

   at DSC.DirectoryFramework.SetupResource(String id, String type, String path, String username, String password, Boolean enabled, IDictionary`2 newSettings)

9/01/2014 14:27:02.4354442     Warning            (DSC.DirectoryFramework) Setting up adDSP 'LDAP://VT.local' wasn't successful: The server is not operational.

Not applicable

Re: Problems with licences

Hi ,

Clear your license and use  http://lef1.qliktech.com/manuallef/   to generate lef and paste in the settings and it will automatically restart qlikview server.


Regards,

Abhishek Neti

Community Browser