Qlik Community

QlikView Deployment

Discussion Board for collaboration related to QlikView Deployment.

Not applicable

QVS Services stopping several times a day

Dear All,

I'm using qlikview for a few years, right now I have a little problem with my Qlikview Server.

For sometimes my QVS services stopping accidentally for any reason.

I'm looking for at all logs file but have no clues, then I look at Event Viewer in Windows Server it tell's something like this :

Application: QVWebServer.exe

Framework Version: v4.0.30319

Description: The process was terminated due to an unhandled exception.

Exception Info: System.ApplicationException

Stack:

   at System.Net.HttpListener.BeginGetContext(System.AsyncCallback, System.Object)

   at QlikView.AccessPoint.HttpServiceComponent.HandleRequest(System.IAsyncResult)

   at System.Net.LazyAsyncResult.Complete(IntPtr)

   at System.Net.ListenerAsyncResult.IOCompleted(System.Net.ListenerAsyncResult, UInt32, UInt32)

   at System.Threading.ExecutionContext.RunInternal(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)

   at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)

   at System.Threading._IOCompletionCallback.PerformIOCompletionCallback(UInt32, UInt32, System.Threading.NativeOverlapped*)

Then I saw all services stopping 1 by 1, so I have to start it again.

I'm using QVS 64bit 11.2 .11643 with Windows Server 2008 R2.

Anyone have an idea to solving this?

Regards,

Effendi

Labels (1)
1 Solution

Accepted Solutions
Not applicable

Re: QVS Services stopping several times a day

hi, for update at the moment,

I have take a look between two servers I have, which one server have no Failover Cluster feature, and the one has it.

So I assume this Failover Cluster feature on Server Configuration is the cause problem.

I will check with my IT infrastructure to talk about this.

I'll be back later for more info.

Thx

12 Replies
preminqlik
Valued Contributor II

Re: QVS Services stopping several times a day

is your server password has been changed?

or see performance in task manager is it getting increased ?

or see if applications size has been increased ?

Not applicable

Re: QVS Services stopping several times a day

1. I have no change any password

2. it looks stable

3. what you mean applications size?

Not applicable

Re: QVS Services stopping several times a day

Since you're on the initial release of 11.20, I would first look at upgrading to a later version. That would also give you the benefit of essentially repairing the QVWS. Also, even though the possibility is remote, I would do a hardware check to make sure none of your disks are having issues.

sudeepkm
Valued Contributor III

Re: QVS Services stopping several times a day

Are you using QV webserver alone or with IIS support?

You may check the Web server setup. I would recommend contacting Qlik Support for any known issue and patch info.

Not applicable

Re: QVS Services stopping several times a day

Hi Joshua thx for your reply, I did upgrade to version 12235, i forgot what is SR version, I'll wait and see is it ok or not today

Not applicable

Re: QVS Services stopping several times a day

Hi Sudeep, thx for your reply, yes i'm using qvs stand alone server..no IIS just using built in qv webserver..i stop all unuse services..the server is not fresh enough..there's several apps like mssql, but i'm sure all unrelated services already turn off..I've upgraded to newer version..we'll see what happen today..

Not applicable

Re: QVS Services stopping several times a day

hello everyone, the error just raise again just a moment, i copied some eror log that i need to know what it's mean..

first this come from exit.log file :

2014-05-06 03:45:00: Spawning KillerThread

2014-05-06 03:45:00: KillerThread calling ServerExit

2014-05-06 03:45:00: ServerExit entered

2014-05-06 03:45:00: Kill child processes still running

2014-05-06 03:45:00: Calling pListener->Close

2014-05-06 03:45:00: Calling CQvMiniHttpsService->Stop

2014-05-06 03:45:00: Calling pACLCache->Close

2014-05-06 03:45:00: Calling pClusterMonitor->Close

2014-05-06 03:40:57: Calling pMetaScheduler->Close

2014-05-06 03:40:58: Calling pPurger->Close

2014-05-06 03:40:59: Calling pGDIPlusChecker->Close

2014-05-06 03:40:59: Calling pLogWriter->Close

2014-05-06 03:40:59: Calling pPgoSync->Close

2014-05-06 03:41:00: Calling ExitThreadWorkerThreads

2014-05-06 03:41:00: Calling ProtExit

2014-05-06 03:41:00: ProtExit entered

2014-05-06 03:41:00: Calling StopSocketMgr

2014-05-06 03:41:00: Calling ExitHttpTunneling

2014-05-06 03:41:00: Deleter is running

2014-05-06 03:41:00: Waiting

2014-05-06 03:41:00: Done

2014-05-06 03:41:00: 0 residual threads

2014-05-06 03:41:00: Calling ExitGdiPlus

2014-05-06 03:41:00: ExitGdiPlus done

2014-05-06 03:41:00: ServerExit done

2014-05-06 03:41:00: Terminating service

2014-05-06 03:41:00: Stopping Cache Trimmer2014-05-06 03:41:00: ExitInstance entered

2014-05-06 03:41:00: Cache Trimmer stopped

2014-05-06 03:41:02: ExitInstance calling base class

2014-05-06 03:41:02: ExitInstance done

Second, coming from event viewer in windows, this information always show up all the time, i don't know it's an eror or what:

The description for Event ID 700 from source QlikViewServer cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

If the event originated on another computer, the display information had to be saved with the event.

The following information was included with the event:

Mount: Browsing D:\QVW_DASHBOARD\. User=QLIKVIEWSVR\Administrator, ImpLev=0

Thx a lot

Re: QVS Services stopping several times a day

In one of the other (very old) threads that you tried to reanimate with this problem, I read that you're running two QVS's in the same network segment. Are you really sure that that they were licensed with different license codes?

If so, then what do you find at the end of the Events log of the QVS that is unexpectedly shutting down? Please post the part immediately before the Exit log is generated.

Not applicable

Re: QVS Services stopping several times a day

Hi Peter,

yes correct, i'm using 2 QVS's with different license, but only 1 QVS that has problem like this.

I post the events log from QVS just right when services stopping,

2014-05-07 14:10:43    2014-05-07 21:06:47    4    700    Information    Debug: CNTService::Handler(1)

2014-05-07 14:10:43    2014-05-07 21:06:47    4    700    Information    Debug: CNTService:Smiley FrustratedetStatus(4151376, 3)

2014-05-07 14:10:43    2014-05-07 21:06:47    4    700    Information    Debug: CNTService:Smiley SurprisednStop()

2014-05-07 14:10:43    2014-05-07 21:06:47    4    700    Information    Debug: Updating status (4151376, 3)

2014-05-07 14:10:43    2014-05-07 21:06:48    4    700    Information    Debug: Done Running

2014-05-07 14:10:43    2014-05-07 21:06:50    4    700    Information    Document PreLoad: Stop

2014-05-07 14:10:43    2014-05-07 21:06:51    4    700    Information    DOC loading: Unloading document D:\QLIKVIEWPUBLISHER\REPORT\LAP_SALESHARIANPERTOKO_TEST.QVW, state UNLOADING.

2014-05-07 14:10:43    2014-05-07 21:06:51    4    700    Information    DOC loading: Unloading document D:\QVW_DASHBOARD_REVISI\DASHBOARD_TEST.QVW, state UNLOADING.

2014-05-07 14:10:43    2014-05-07 21:06:55    4    700    Information    Debug: CNTService:Smiley FrustratedetStatus(4151376, 1)

2014-05-07 14:10:43    2014-05-07 21:06:55    4    700    Information    Debug: Leaving CNTService:Smiley FrustratederviceMain()

2014-05-07 21:06:57    2014-05-07 21:06:58    4    700    Information    NUMA: NUMA nodes enabled

2014-05-07 21:06:57    2014-05-07 21:06:58    4    700    Information    WorkingSet: Configured Working Set Size is 358.391-460.788 GB (setting 70%-90%)

2014-05-07 21:06:57    2014-05-07 21:06:59    4    700    Information    Debug: Calling StartServiceCtrlDispatcher()

2014-05-07 21:06:57    2014-05-07 21:06:59    4    700    Information    Debug: Entering CNTService:Smiley FrustratederviceMain()

2014-05-07 21:06:57    2014-05-07 21:06:59    4    700    Information    Debug: CNTService:Smiley FrustratedetStatus(3627088, 2)

2014-05-07 21:06:57    2014-05-07 21:06:59    4    700    Information    Debug: CNTService:Smiley FrustratedetStatus(3627088, 4)

2014-05-07 21:06:57    2014-05-07 21:06:59    4    700    Information    PGO: Creating file IniData.pgo

2014-05-07 21:06:57    2014-05-07 21:06:59    4    700    Information    Mount: Found Mount  at location D:\QVW_Default  browsable

2014-05-07 21:06:57    2014-05-07 21:06:59    4    700    Information    Mount: Found Mount IDMMonitoring at location D:\QVW_Monitoring  browsable

2014-05-07 21:06:57    2014-05-07 21:06:59    4    700    Information    Mount: Found Mount Dashboard at location D:\QVW_DashBoard  browsable

2014-05-07 21:06:57    2014-05-07 21:06:59    4    700    Information    Mount: Found Mount Dashboard_revisi at location D:\QVW_Dashboard_revisi  browsable

2014-05-07 21:06:57    2014-05-07 21:06:59    4    700    Information    Mount: Found Mount QlikviewPublisher at location D:\QlikviewPublisher not browsable

2014-05-07 21:06:57    2014-05-07 21:07:00    4    700    Information    Document PreLoad: Start

2014-05-07 21:06:57    2014-05-07 21:07:01    4    700    Information    Debug: CNTService::Handler(4)

2014-05-07 21:06:57    2014-05-07 21:07:01    4    700    Information    Debug: CNTService:Smiley SurprisednInterrogate()

2014-05-07 21:06:57    2014-05-07 21:07:01    4    700    Information    Debug: Updating status (3627088, 4)

2014-05-07 21:06:57    2014-05-07 21:07:11    4    700    Information    Mount: Browsing D:\QVW_DEFAULT\. User=QLIKVIEWSVR\Administrator, ImpLev=0

Mostly I read from many threads in community has this logs, but no one can answer or solve.

I need to find a reason and telling to my boss before I formatting all my server.

Is there some experiences that failed reload schedule can turning off all services?

I already set the NUMA setting also in settings.ini as I found the thread here, but still cannot fix this.

I disable all reload schedule yesterday, and still happen last night twice.

All the logs file I learn nothing tells more about the stopping services, it just 'boom', the services said 'I want to stop, I'm tired'

Please tell me if there is another log files you need.

PS: I have already upgraded into QVS 11.2.12235 version

Thx

Community Browser