Qlik Community

QlikView Deployment

Discussion Board for collaboration related to QlikView Deployment.

Not applicable

Setting QlikView 9 + 2008 + IIS 7 (Tunneling)

Hi, I install QVS 9 (build:7320) on Windows Server 2008R2 (X64) with IIS7 (IIS 7).

Try to configure it to use tunneling, but i have no luck:

I register qvstunnel.dll as web-extension (IIS > ISAPI and CGI Restrictions > Add...), restart IIS, then server..

error loading image

But when try to test tunnel (http://localhost/scripts/qvstunnel.dll?testtunnel) IE open file download menu..

error loading image

Don't know what I did wrong???

Thanks!

1 Solution

Accepted Solutions
vgutkovsky
Honored Contributor II

Setting QlikView 9 + 2008 + IIS 7 (Tunneling)

First of all, make sure that QvsTunnel.dll has only been defined as an ISAPI and CGI Restriction and not as an ISAPI filter. Next, open an elevated command prompt (Start>Programs>CMD, right click, select run as Administrator) and enter the following:

%windir%\system32\inetsrv\appcmd.exe set config "Default Web Site/Scripts/QvsTunnel.dll" "/commitSmiley Very Happyefault Web Site/Scripts" /section:handlers /accessPolicy:Read,Script,Execute


You should get this message in response:

Applied configuration changes to section "system.webServer/handlers" for "MACHINE/WEBROOT/APPHOST/Default Web Site/Scripts/QvsTunnel.dll" at configuration commit path "MACHINE/WEBROOT/APPHOST/Default Web Site/Scripts"


That's it--should work now.

9 Replies
vgutkovsky
Honored Contributor II

Setting QlikView 9 + 2008 + IIS 7 (Tunneling)

First of all, make sure that QvsTunnel.dll has only been defined as an ISAPI and CGI Restriction and not as an ISAPI filter. Next, open an elevated command prompt (Start>Programs>CMD, right click, select run as Administrator) and enter the following:

%windir%\system32\inetsrv\appcmd.exe set config "Default Web Site/Scripts/QvsTunnel.dll" "/commitSmiley Very Happyefault Web Site/Scripts" /section:handlers /accessPolicy:Read,Script,Execute


You should get this message in response:

Applied configuration changes to section "system.webServer/handlers" for "MACHINE/WEBROOT/APPHOST/Default Web Site/Scripts/QvsTunnel.dll" at configuration commit path "MACHINE/WEBROOT/APPHOST/Default Web Site/Scripts"


That's it--should work now.

Not applicable

Setting QlikView 9 + 2008 + IIS 7 (Tunneling)

Thanks a lot!

Now it's work!

elbertfjr22
New Contributor III

Setting QlikView 9 + 2008 + IIS 7 (Tunneling)

Thanks also a lot for this one Vlad. How we will able to do this if it's not on the manual!

Saved my day :-)

Regards,

Elbert

amien
Valued Contributor

Setting QlikView 9 + 2008 + IIS 7 (Tunneling)

Thanks alot!

amien
Valued Contributor

Setting QlikView 9 + 2008 + IIS 7 (Tunneling)

saved me twice. . thanks Smiley Happy its really change that in the first days of the server, i didnt get this error message, and at some point, people start getting this error message. And i didnt change anything on the server. It seems also that all people are tunneling now. So i cant explain why i get this message now, and before not.

Not applicable

Setting QlikView 9 + 2008 + IIS 7 (Tunneling)

Had the same problem for IIS7 / QlikView 11 when using IE plugin together with tunnelling, and this solved my problem! Is there any way to do that through IIS7 GUI?

vgutkovsky
Honored Contributor II

Setting QlikView 9 + 2008 + IIS 7 (Tunneling)

No way to do that through the UI as far as I know

Employee
Employee

Re: Setting QlikView 9 + 2008 + IIS 7 (Tunneling)

See if this will help.

Highlighted
vgutkovsky
Honored Contributor II

Setting QlikView 9 + 2008 + IIS 7 (Tunneling)

Bill, my fix above is to fix a bug with that UI method.

Vlad

Community Browser