Qlik Community

QlikView Deployment

Discussion Board for collaboration related to QlikView Deployment.

Not applicable

prohibit anonymous option

Hi all!

I have a problem when i try to change an option on the QEMC: when i try to change the QEMC->System->Setup->Qlikview server->Security->authentication client option into "Allow anonymous" or "Always anonymous" and i apply, the server doesn't save what i have done and the option returns to "prohibit anonymous"

Please help me!

thanks!!!

10 Replies
MVP
MVP

prohibit anonymous option

Hello,

What kind of license are you using in your server (Small Business, IAS, Enterprise)? How are you identifying your users, NTFS or DMS?

I'd give a restart to services anyway.

Not applicable

prohibit anonymous option

I have a Small business edition and i use NTFS (so i have add to the documents the Local computer Anonymous user).

Thanks!

MVP
MVP

prohibit anonymous option

Verify that the IQVS_ServerName as local machine account exists and have permissions in the folders you want to use for your documents. Does the services restart normally when you apply the changes after checking one of the radio buttons for "Allow Anonymous"?

Not applicable

prohibit anonymous option

I have just added the IQVS_xxxx users to the document folder with all the permissions. I have also restarted all the qlikview services.

When i check the radio button there aren't any problem on the services that restart normally.

But doing these things doesn't resolve the problem.

I don't know why!!

thanks!

Not applicable

prohibit anonymous option

Maybe is it possible to be a problem connected to the CALs?

thanks

MVP
MVP

prohibit anonymous option

My guess is that your license doesn't allow anonymous access (session CALs). Although there is a post here for changes not stored properly, my conclusion is that since you only have Named CALs or Document CALs, anonymous user is not allowed to access documents. Check this post for further tips, just in case.

I recommend you to speak to your QlikView sales rep and discuss about your deployment and licensing needs.

Hope that helps.

Not applicable

prohibit anonymous option

thank you very much!!!

Not applicable

prohibit anonymous option

thanks!

in fact i have only Named CALs. So as you say i have not the possibility to use the anonymous user to access the documents! Right?

thank you again!

Employee
Employee

prohibit anonymous option

You can't use anonumous with SBE server.