Qlik Community

QlikView Deployment

Discussion Board for collaboration related to QlikView Deployment.

Highlighted
amberspt
New Contributor

server uses only 1 thread

Hello all,

I have a problem in the Qlikview server performance. it seems that although we have 32 cores, the server uses only 1 thread when processing. The CPU stands on about 3-4% in total, but we see 1 thread that works on 100% and the rest of them do nothing.

First we encountered it when our clients complained about the system being really slow and some times even not being able to build some reports in dynamic table (we use ajax for access point). Then we tried to see what happens when using the desktop and it was the same.

The 3rd test was reloading a simple test QVW, that just creates 1 auto-generate simple table. We saw the same outcome in the CPU during the reload.

We tried the following settings with all combinations, but non of them made it any better:

1. hyper threading - enabled/ disabled

2. 1 CPU / 2 virtual CPU

The server runs as VM on VMware ESXi host with 2 x Intel Xeon E5-2698 v3 (40M Cache, 2.30GHz) and uses DDR4 @ 2133MHz memory. The processors has Max Turbo Frequency of 3.60GHz.

The server is separated from the publisher, who works on a different machine.


see screen shot attached.

2 Replies
Partner
Partner

Re: server uses only 1 thread

Hi amberspt

Just be shure that all the cores are available(checked) in QMC in performance tab

qwd.jpg

idogridish2
Contributor II

Re: server uses only 1 thread

Hi amberspt

I have the same issue,

how did you solved that problem?

Best Regards,

Ido.