Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Dynamic DIV-tag integration

With QlikView 11 we introduced a feature with the sexy name DIV-tag integration.

What this really enables us to do is to reference our JavaScript API and integrate QlikView Objects into web solutions with full functionality.

This is huge. With no extra licenses QlikView users around the world can now enjoy QlikView functionality within non .Net solutions, embedded into their ERP or CRM systems. The community loved it but was also a bit concerned that the amount of objects floating around out there would increase the maintenance of QlikView.

A few lines of JavaScript will eliminate that problem for you

Dynamic DIV-tag integration 1.0

Now you have 1 solution to maintain that can serve your entire company with embedded QlikView Objects.

Short version:

You will need:

QlikView Server version 11 installed.

Some sort of web server.

A can of coke and a smile on your face.

NEW: A workbench license.


1. Download the sample at:

2. If you are running QV Webserver extract the contents to: C:\Program Files\QlikView\Web\

3. Change the script references in single.htm to match your setup.

4. And you are done.


The solution accepts input according to the following syntax: http://WebServerUrl/app pool/single.htm?app=your document without qvw&obj=ObjectID

Optional parameters are w and h to set width and height otherwise default to 100%

On my demo system the following URL will generate the chart below:


NOTE: If you get a no connection error message try adding the .qvw extension to your app variable


This chart has full QlikView functionality. If you for some reason want to disable any interaction with the object, set it to read-only in the QV document.

32 Replies
Partner - Creator II
Partner - Creator II

Hello Alexander,

when i start playing with div-tag integration i've always get a message "No connection". But when i've added ".qvw" for the "app" parameter ("app=your document without qvw&obj=ObjectID"), i got a working solution.  So, the "app" parameter should contain application's name including extension, isn't it?


Hmm, that is strange. What QV version are you running?

The app parameter is used in the initworkbench method and the avqviews in the DIVs.

These should normally not require a .qvw extension

Partner - Creator II
Partner - Creator II

I'm using QlikViewServer 64-bit Edition (x64) 11.00.11282.0. The authorization is set as "DMS authorization".


Strange, same setup as I'm running. Tested it with both IE, Chrome and Firefox and it runs fine on my box.

Oh well, it should work with .qvw extension aswell our jsapi should be able to handle both versions.

Not sure if I should dig more into it after the beatdown you guys gave Sweden last night

Partner - Creator II
Partner - Creator II

Thanks anyway!

Not sure if I should dig more into it after the beatdown you guys gave Sweden last night

Partner - Contributor II
Partner - Contributor II

You used the phrase "With no extra licenses," but I want to point out that you need a Workbench license in order for this to work.

If you don't have a Workbench license, you will get a "Failed to Authenticate" error, a "No connection" error, or a blank page on the client side in the browser.

On the server side, you will see this message in the QVWS logs:

   Warning    Failed to get client: WORKBENCH license missing

Just pointing this out so nobody else spends a lot of time troubleshooting their HTML code like I did!


Hey Patrick,

When the feature was released we double and tripple checked with out licensing department around it. The word that came back was that no, you do not need a workbench license and I'am fairly sure I tried it without workbench licneses on a fresh QV11 box,

What version are you running?

I'll reach out internally again and see if anything has changed regarding this.

Partner - Contributor II
Partner - Contributor II

Thanks for the response, Alexander.

I am using QVS 11.00.11154.0 IR 64-bit Edition.

I'll see if I can find an 11SR1 or 11SR2 instance somewhere to see if I can reproduce the issue there.

In the meantime, can you double check my HTML code to see if I am doing something incorrect?  I have tried it with and without the "Qv.InitWorkBench" line and got the same results.



  <TITLE> QV Div-tag Test </TITLE>

  <script type="text/javascript" src=""></script>

  <script type="text/javascript">Qv.InitWorkBench({ View: 'QlikView Demo'});</script>



   <div style = "width:400px;height:250px;">

     <div class="qvFrame" avqview="QlikView Demo" avq="object:.Document\CH11" id="Document\CH11" style="width:400px;height:250px;"></div>




Not applicable


I'am trying to use the sample on our server, but it's not working

First message "Failed to authenticate" followed by two more ones "No connection"

I picked what I suppose to be the version in "QlikView management console"

Product nameQlikView Web Server Settings Service
Client Build Number11.0.11414.0

The installation is not completely standard as the server root directory is not C:\Program Files\QlikView\Web\

I have checked single.htm javascripts are correctly loaded

On the app side, is there some relative path to specify ? Indeed, changing app name to something fool give the same "crashing" scenario.

Thanks for your attention