Qlik Community

QlikView Management

Discussion Board for collaboration on QlikView Management.

Contributor II

Problems with User Cal after upgrade to QlikView11


I have run into some problems after upgrading an environment from QV10 to to QV11. Some of the users get the message “The server has no USER CAL for your account. Please contact your administrator”. Only on some application, not all. All users have a User Cal

I tested following user “#qv-admin” that has a User Cal on the server.

If I open the application ORDERINGANG-2011.QVW  I receive the message.

If I open ARTIKEL.QVW everything is ok.

Any idea why we got this behavior from the AccessPoint?

Server Started          Timestamp          SeverityID          EventID          Severity          Message

2011-12-14 15:32:13          2011-12-14 15:36:47          4          700          Information          Ticket created: Ticket for SLIPNAXOS\#qv-admin.

2011-12-14 15:32:13          2011-12-14 15:36:47          4          700          Information          Ticket Lookup: Ticket EBDF4D3C8C711D953498D627310AE5C4F045BDA6 was found.

2011-12-14 15:32:13          2011-12-14 15:36:47          4          700          Information          DOC loading: Beginning load of document C:\SHARED\QV\PUBLIC DATA\ACCESSPOINT\ORDERINGANG-2011.QVW.

2011-12-14 15:32:13          2011-12-14 15:36:47          4          700          Information          Document Load: The document C:\SHARED\QV\PUBLIC DATA\ACCESSPOINT\ORDERINGANG-2011.QVW was loaded.

2011-12-14 15:32:13          2011-12-14 15:36:48          1          300          Error          Restart: Server aborted trying to recover by restart. Reason for restart: Internal inconsistency, general exception detected during document open.

2011-12-14 15:32:13          2011-12-14 15:36:50          4          700          Information          Document PreLoad: Stop

2011-12-14 15:32:13          2011-12-14 15:36:51          4          700          Information          DOC loading: Unloading document C:\SHARED\QV\PUBLIC DATA\ACCESSPOINT\ORDERINGANG-2011.QVW, state UNLOADING.

2011-12-14 15:36:54          2011-12-14 15:36:55          4          700          Information          WorkingSet: Configured Working Set Size is 3.500-4.500 GB (setting 70%-90%)

2011-12-14 15:36:54          2011-12-14 15:36:55          4          700          Information          PGO: Creating file IniData.pgo

2011-12-14 15:36:54          2011-12-14 15:36:55          4          700          Information          Mount: Found Mount  at location C:\Shared\qv\Public Data\AccessPoint  browsable

2011-12-14 15:36:54          2011-12-14 15:36:56          4          700          Information          Document PreLoad: Start

2011-12-14 15:36:54          2011-12-14 15:36:58          4          700          Information          Ticket created: Ticket for SLIPNAXOS\#qv-admin.

2011-12-14 15:36:54          2011-12-14 15:36:58          4          700          Information          Ticket Lookup: Ticket 3FB15FA8F06A34792B8CD5454B107F6F7D8219B0 was found.

2011-12-14 15:36:54          2011-12-14 15:36:58          4          700          Information          DOC loading: Beginning load of document C:\SHARED\QV\PUBLIC DATA\ACCESSPOINT\ARTIKEL.QVW.

2011-12-14 15:36:54          2011-12-14 15:37:00          4          700          Information          Document Load: The document C:\SHARED\QV\PUBLIC DATA\ACCESSPOINT\ARTIKEL.QVW was loaded.

2011-12-14 15:36:54          2011-12-14 15:37:00          4          700          Information          CAL usage: Named CAL "SLIPNAXOS\#QV-ADMIN" now used - ok.

2011-12-14 15:36:54          2011-12-14 15:37:00          4          100          Notice          CAL usage: Using CAL of type "Named User" for user "SLIPNAXOS\#QV-ADMIN". Named user cals in use: 1

2011-12-14 15:36:54          2011-12-14 15:37:06          4          700          Information          Mount: Found Mount  at location C:\Shared\qv\Public Data\AccessPoint  browsable

I can add the information that I move the environment to a new machine during the upgrade but have tested on the “old” server as well and still get the same behavior with QV11

4 Replies
Contributor II

Re: Problems with User Cal after upgrade to QlikView11

Problem solved.

I deleted All User Cal (and Doc Cal in case of).

Deleted *.pgo

Switch to Dynamic update of User Cal

Rerun the all Publisher Task

Open AccessPoint and tested all Applications as QV-Admin (Ok)

Let some end user with problems tested (Ok)

Now we gone added all Doc Cal again.

The problem was quite easy to fix but little disturbing and took some time to fix. Any idea why this happens? Have a lot of QV11 upgrades planed and I don’t want this happen again.

It is quite often a customer changes server during an upgrade. Should the *.pgo also been lifted to the new server or should it be a rule to add users again and let the QV Server create this files on the new server? Any differing if it is only User Cal compare with User Cal and Doc Cal on the server?

I’m sorry if I have misunderstood the function of the *pgo and the description above don’t sounds as it should be working.

Contributor II

Problems with User Cal after upgrade to QlikView11

I would suggest reading this migration document which details which files to move from one environment to another (v10 to v11).


Contributor III

Problems with User Cal after upgrade to QlikView11

I am experiencing exactly the same error on QV10 SR4, without having even downloaded QV11 to either the reload/distribution server or the access point server.

Have tried the above suggested steps (deleting PGO files, re-distributing the QVW etc) - no luck. That particular QVW (which is actually just a freshly created, empty QVW) fails to distribute properly.

Same thing happens for all newly created QVWs, it seems.. Quite disturbing.

I am also noting another warning message in the Windows Server log:

Session Recovery Failed: The document abc.qvw failed to apply $LASTKNOWNSTATE

Don't know if it's related.

Any ideas, anyone?


Contributor III

Problems with User Cal after upgrade to QlikView11

Problem solved.

Turned out to be corrupt PGO files on the access point. Note that the PGO files resides in two places, both in c:\ProgramData\QlikTech\QlikViewServer and in the accespoint root folder.


1. Stop the QV services

2. Delete the .pgo files (back them up if you want to play it safe).

3. Restart services.

4. You might need to distribute the documents again, at least if you use document CALs (so the appropriate users get access to the right documents). At least I needed to do this to fully resolve the problem.

Case closed.


Community Browser