Qlik Community

Ask a Question

QlikView Management

Discussion Board for collaboration on QlikView Management.

Announcements
Talk to Experts Tuesday, January 26th at 10AM EST: Qlik Sense. REGISTER NOW
cancel
Showing results for 
Search instead for 
Did you mean: 
Creator
Creator

Qlikview Server : .NET Framework used is not the good

Hello,

We have recently upgraded our Qlikview version from 11.20 to 12.10.

In system requirements it's indicated that .NET Framework needed is 4.5.2 or higher.

When I look on my server, it seems that we have the good version installed:

net framework.jpg

But when I look on Qlikview Server informations, it seems that an older version is used.

version server.jpg

How is it possible?

Thanks and regards

Sara

1 Solution

Accepted Solutions

Using Chip's link to figure out what the actual (?) version number of your .NET installation is, I came up with this.

.NET Version 4.0.30319.36399 refers to a Security patch for .NET 4.5.2 on Windows Server 2012.

See: https://support.microsoft.com/en-us/help/4040975/security-and-quality-rollup-for-net-framework-4-5-2...

(It may also refer to a comparable patch for versions of .NEt on other platforms. Who knows.)

Anyway, I think you're good with your version of .NET. But in order to resolve any remaining problems with QlikView Server on this particular version of .NET, you may still want to install updates, or upgrade to a later version.

If you don't feel comfortable with this feedback, please contact Qlik Support. I'm sure they have a solution that fixes the problem instead of just doing something with .NET versions.

View solution in original post

6 Replies

Are you having operational problems with the installed .NET version, e.g. is QlikView Server not working as expected?

AFAIK .NET version numbers are a mess...

Creator
Creator

Hello,

Yes, we are encountering this problems:

  Error      The task "XXXXXXXXX.qvw" failed. Exception: QDSMain.Exceptions.TaskFailedException: Task execution failed with errors to follow. ---> System.ArgumentNullException: La valeur ne peut pas être null.

And I know that this problem appears when the version of .NET Framework is not ok.

You can try upgrading to 4.6.2 or later.

Why is your system carrying both the Client and the Full .NET package?

Support
Support

Hi Sara,

The .NET Framework listed in the QMC > System > About is .NET build version.

I typically use this link to help decipher the runtime .NET version from the official build version: How to reliably detect the actual .NET 4.5 version installed? - Stack Overflow

Hope this helps!

-Chip

Sr. Technical Support Engineer with Qlik Support

Using Chip's link to figure out what the actual (?) version number of your .NET installation is, I came up with this.

.NET Version 4.0.30319.36399 refers to a Security patch for .NET 4.5.2 on Windows Server 2012.

See: https://support.microsoft.com/en-us/help/4040975/security-and-quality-rollup-for-net-framework-4-5-2...

(It may also refer to a comparable patch for versions of .NEt on other platforms. Who knows.)

Anyway, I think you're good with your version of .NET. But in order to resolve any remaining problems with QlikView Server on this particular version of .NET, you may still want to install updates, or upgrade to a later version.

If you don't feel comfortable with this feedback, please contact Qlik Support. I'm sure they have a solution that fixes the problem instead of just doing something with .NET versions.

View solution in original post

Creator
Creator

Hello,

We have updated the .Net version and all works fine now.

Thanks and Regards

Sara