Qlik Community

QlikView Publisher

Discussion Board for collaboration on QlikView Publisher.

Announcements
QlikView Fans! We’d love to hear from you.
Share your QlikView feedback with the product team… Click here to participate in our 5-minute survey.
Rules, plus terms and conditions, can be found here.
Not applicable

Problem to download file from Access Point

Hello,

We have qlikview server with MS Server 2003 with Qlikview v9 with NTFS Authorisation for qlikview files.

All clients AJAX, IEPlugin, Java work OK but the download options doesn't.

error loading image

I checked access rights in Security tab for our files and also Qlikview Management ,and Server console (Allow download) but everything seems to be OK.

Has anyone experienced the same problem ?

10 Replies
vgutkovsky
Honored Contributor II

Problem to download file from Access Point

Looks to me like the URL might be incorrect. Can you paste the autogenerated Download URL here?

Another likely problem is that the Download method has been disabled for that file in QEMC --> User Documents.

Regards,

Not applicable

Problem to download file from Access Point

Hi Vlad,

I'm sorry for little confussion here, I hided the server name. Here is the link I get when I click on Download in Access Point :

https://ourserver.ourdomain.corp/QvAJAXZfc/AccessPoint.aspx?open=&id=QVS@ourserver%7CInventory_EMEA_...

I did check Download options in QEMC (System - Allow Document Download and also in Documents for each document itself) and also in QMC but no luck. Seems to be that QVS is just can't get an access to the file. I have changed security for our files in Security tab (everyone - full access) but no luck. I even restarted QVS services.

This is what I get : (it's just stuck here and after a while I get the message that the file can't be downloaded)

Strange ....

BTW : Interesting is that there is QvAJAXZfc in the link - does it mean anything ?

vgutkovsky
Honored Contributor II

Problem to download file from Access Point

The QvAJAXZfc in the URL is normal--it exists because AccessPoint is built on AJAX. This does not mean that the client is AJAX.

I was able to recreate the problem on my test server. It looks like this is an IE problem, where IE tries to download the ASP file rather than the QVW it links to. This behavior doesn't happen in Firefox. So I would recommend either using Firefox with AccessPoint OR removing the download link from index.htm in C:\Program Files\QlikView\Web and then having the users download QVWs by selecting "Open in Server" inside QlikView Desktop. Plus, I think it would be a good idea to report this to QlikTech as a bug (support@qlik.com).

Regards,

Not applicable

Problem to download file from Access Point

Hi Vlad,

Confirmed, same behaviour here ... I'm going to contact Qlikview Support.

Thank you for your time and help !!!

vgutkovsky
Honored Contributor II

Problem to download file from Access Point

Just figured this out. You need to change the following IE security settings client-side for the zone that your server is in (probably Intranet):

Download Unsigned ActiveX Controls = Prompt
Initialize and script ActiveX controls not marked as safe for scripting = Prompt
Access data sources across domains = Prompt

Also make sure you're automatically prompting for File Downloads. These settings fixed the problem for me, let me know if it works for you.

Regards,

Not applicable

Problem to download file from Access Point

Hi Vlad,

Good thinking. I checked this on IE6 however it's still not working (tested on Intranet and Alowed Servers, different users, IE reset to original settings, lowest security) - probably our problem is somewhere else. I will try to do more tests on IE7 or IE8. Also I'm in contact with Qlikview support.

vgutkovsky
Honored Contributor II

Problem to download file from Access Point

Well, IE6 is actually not supported with QVS9, so don't get discouraged if it doesn't work...any luck on IE7 or 8?

Not applicable

Problem to download file from Access Point

I have tested in IE8 with DMS authorization. But it does not work, it throw an error when it download in 99%........But it works when I do the same thing on server. I pressed "http://localhost/qlikview", and IE works.... Strange!!!!!!

Not applicable

Problem to download file from Access Point

More tests done IE 8 but still no luck. Now waiting for a response from qlikview support. Hopefully they will help ... Meanwhile we let users to download files via local qlikview app.

Community Browser