Qlik Community

QlikView Security & Governance

Discussion Board for collaboration on QlikView Security and Governance.

Announcements

Breathe easy -- you now have more time to plan your next steps with Qlik!
QlikView 11.2 Extended Support is now valid through December 31, 2020. Click here for more information.

nehasaxena
Contributor II

How to allow users to access object properties in access point?

Hello All,

I have gone through so many posts on the community but unable to find any answer for this question. Is it possible for users to access the properties of existing sheet objects in web?

I have checked the box in security settings but not working

Any suggestions will be really helpful for me.

Thanks,

Regards

Neha

1 Solution

Accepted Solutions

Re: How to allow users to access object properties in access point?

Then you just need to uninstall/reinstall the IE plugin.

Quickest way is to copy the installer from the QlikView Server and run it again. On your server, check C:\Program Files\QlikView\Server\QlikViewClients\QlikViewPlugin. There should be two installers in that directory.

If you installed QV Desktop on your laptop/desktop, upgrade QV Desktop.

Peter

18 Replies
vardhancse
Valued Contributor III

Re: How to allow users to access object properties in access point?

Enable ->apply All Sheets(check box)

or

Settings->Document Properties->Security

Once check the options.

Or

Or else because of section access might be the properties are disabled.

Re: How to allow users to access object properties in access point?

Note that all sheets and objects that were defined by the developer in the original QVW document cannot be modified by anyone in the AccessPoint. Even if you succeed in making available a Properties... dialog in the AccessPoint, all properties will be grayed out.

If that is the problem you are facing, then there is no way around it. However, if you just make a copy of the object for which you want to check the properties, the properties of that new object can be inspected and modified in the AP since you created it yourself.

Best,

Peter

gautik92
Valued Contributor III

Re: How to allow users to access object properties in access point?

Settings->Document Properties->Security->Admin OverrideSecurity

MVP
MVP

Re: How to allow users to access object properties in access point?

That helps if you have opened the document as an ADMIN. When you open the document on the portal, you are always and only in USER mode, regardless of the section access rules.

Logic will get you from a to b. Imagination will take you everywhere. - A Einstein
nehasaxena
Contributor II

Re: How to allow users to access object properties in access point?


Thank You Peter for your reply!!

At least now I have clarity about this, will see what I can suggest my users.

Regards,

Neha

nehasaxena
Contributor II

Re: How to allow users to access object properties in access point?

Hi Peter,

I am getting another issue - I am unable to copy the object if it exists in container. Copy option is enable but paste is disable. I can copy the container but not any object

Am I missing anything in the properties?

Many thanks in advance!

Neha

Re: How to allow users to access object properties in access point?

If you managed to really select the contained object no, not to my knowledge. Even in QV Desktop, objects in containers have always been difficult to copy, and when you paste them they often maximize without any reason. Maybe this is just a bug.

But I'll first try it myself.

Peter

Not applicable

Re: How to allow users to access object properties in access point?

Hello Jonathan, i tried reply on this post with a question:

https://community.qlik.com/thread/54342

It is about loading excel, but in my case by each row, and everytime it loops i want it to also check if that row exists in the qvd ,

Re: How to allow users to access object properties in access point?

It works for me. I  am able to make a copy of a bar chart embedded in a container, and paste it on a sheet for which I have permission to make modifications (or on a new sheet I created in the AP).

Something else must be blocking you from doing the same. Did you check the sheet permissions? Or can you create a new sheet and try again on that one?

Best,

Peter