Qlik Community

QlikView Security

Discussion Board for collaboration on QlikView Security.

johnan
Contributor III

Allow unsafe macro

Hi, we have a serversolution and the user is getting access by AD. We have some QV's with built macro.

The thing is when you for the first time open the document as a user with Macro, you got 3 choices. Block or Run and run for this user (or something). If you choose wrong you will never get that option again. Can someone tell me how i can change that so you can change next time you open the document again?

Thanx

John

Tags (1)
1 Solution

Accepted Solutions

Re: Allow unsafe macro

Hi John,

Press Ctrl + Shift + M.

Capture.PNG

7 Replies

Re: Allow unsafe macro

Hi John,

Press Ctrl + Shift + M.

Capture.PNG

johnan
Contributor III

Re: Allow unsafe macro

Okay, so the user can do this when openened the document with the IE-plugin?

Re: Allow unsafe macro

Yes. The above screen shot captured from the IE after opening the document.

johnan
Contributor III

Re: Allow unsafe macro

Okay, i will test this. Maybe i have to change some security setting on the document on the server?

Re: Allow unsafe macro

1. Make sure you allow "System access"in the document. (After opening the document press Ctrl + M, bottom left drop down, you can see the options)

2. Make sure you are granting System Access to your macros in the server through QEMC.

System -> Setup -> QlikView Servers -> expand and click -> Seucrity tab -> Add tick mark for "Allow macro execution on server".

That's all.

johnan
Contributor III

Re: Allow unsafe macro

Worked, thanx

Re: Allow unsafe macro

No problem John. Have a good day!!

Community Browser