Qlik Community

Scalability

Announcements
Coming Aug. 9: New Simplified Authoring for Qlik Sense SaaS – For Details, CLICK HERE
cancel
Showing results for 
Search instead for 
Did you mean: 
Daniel_Larsson
Employee
Employee

Qlik Sense Scalability Tools Connection Troubleshooting Tips

I put together check lists as a help troubleshooting connection settings problems when using Qlik Sense Scalability Tools.

Using header auth

  1. Is the app published?
  2. Can you connect manually to the virtual proxy with header auth using modify header plugin in firefox, fiddler or similar.
    1. If it works, make sure the user which get logged in is the one from the header not your ntlm user.
    2. Can the header user access the app you want to simulate?
  3. If manual connection (1) with header works, make sure all these settings correspond to your tool settings
    1. VirtualProxyPrefix settings same as Prefix defined in QMC on the virtual proxy
    2. HeaderName same as Header authentication header name on the virtual proxy
    3. ConnectionType set to Header.
    4. Server is set to the same server name as the certificate, default fully qualified domain name, without defining protocol etc, i.e. myserver not https://myserver/hub.
    5. A default sense installation uses https and a self-signed certificate. Make sure the SSL checkbox is checked when using SSL or TLS (default) and the AllowUntrustedCertificate checkbox is checked if using the self-signed or any other “untrusted” certificate.
  4. If Connect to App doesn’t work, try doing a simple scenario of 1 user 1 iteration with only a small timerdelay in the scenario, then execute this using the executor (i.e. not connect to app). Does this get any errors?
  5. If you are getting license access denied, make sure the header users have an appropriate amount of tokens allocated.

Using NTLM auth

  1. Make sure the user has access to the app by manually connecting to it.
  2. If manual connection (1) with header works, make sure all these settings correspond to your tool settings
    1. VirtualProxyPrefix settings same as Prefix defined in QMC on the virtual proxy or blank if using root (default)
    2. ConnectionType set to NTLM.
    3. Server is set to the same server name as the certificate, default fully qualified domain name, without defining protocol etc, i.e. myserver not https://myserver/hub.
    4. A default sense installation uses https and a self-signed certificate. Make sure the SSL checkbox is checked when using SSL or TLS (default) and the AllowUntrustedCertificate checkbox is checked if using the self-signed or any other “untrusted” certificate.
  3. If Connect to App doesn’t work, try doing a simple scenario of 1 user 1 iteration with only a small timerdelay in the scenario. Does this get any errors?
  4. If you are getting license access denied, make sure the header users have an appropriate amount of tokens allocated.
Labels (1)
21 Replies
vegard_bakke
Partner - Creator III
Partner - Creator III

Yet another one struggling with 'Please verify NTLM user and app!'

Is the Scalability Tool logging the connection somewhere?   Can I see the frames that Qlik Sense sends on the websocket?

It would have been great if we could separate the logging in, and opening the app. To better know where to debug.   

By first complete the login, the tool could even fetch the list of available apps.  This way, it will confirm that the NTLM itself is working. As well as eliminating the chance of choosing an app that the user doesn't have access to.

RubendeEusebio
Partner - Contributor
Partner - Contributor

Hi, I'm not able to connect to the app structure by NTLM connection. I have the next error:

Failed to get app structure: Failed to connect to application

 

If I try to execute a simple scenario but the same error occurs.

I've checked that I can connect manually to the app, virtual proxy works and tokens are assigned for user .

Could you help me?

Thanks, Rubén

 

Daniel_Larsson
Employee
Employee
Author


@RubendeEusebio wrote:

 

If I try to execute a simple scenario but the same error occurs.

I've checked that I can connect manually to the app, virtual proxy works and tokens are assigned for user .


 Hi,
Thank you for trying those things first.

There might be a bug related to the SDK for June release specifically affecting some users connecting with NTLM. For those using sept or nov instead solves the problem. Haven't been able to reproduce it myself, so may I ask , if you can say.

1. What's the windows version of the load client?
2. What's the windows version of the server?
3. Which release are you choosing in the tool?

RubendeEusebio
Partner - Contributor
Partner - Contributor

Hi,

Thank you for your reply.

 

The Windows versions of the server and load client are Windows Server 2016 on both

and I use Qlik Sacalability Tools v5.10.1

 

Regards,

Daniel_Larsson
Employee
Employee
Author

For what we can see this is exclusively a problem with the the Jun2020 option. Will upload a version fixing this, however until then, choosing one version later is the workaround.

Daniel_Larsson
Employee
Employee
Author

NTLM problems for June 2020 option should now be fixed in v5.11.1

krishnakumars7
Partner - Contributor III
Partner - Contributor III

I am using V5.12.3, I created one scenario  and in tried three different network,

Inside QlikSense Server - Working Fine

Inside One of the client network - Working Fine

Inside another Client network - Throwing websocket error.

But I can qliksense url for all the three sites, 

What could be the possible issue and how to debug on it. 

Regards

Krishna Kumar S

Daniel_Larsson
Employee
Employee
Author


@krishnakumars7 wrote:

Inside another Client network - Throwing websocket error.


What's the error?


@krishnakumars7 wrote:

But I can qliksense url for all the three sites, 


 

Sorry, don't understand what this means?

krishnakumars7
Partner - Contributor III
Partner - Contributor III

Hi Daniel,

Please find the error message screenshot attached

krishnakumars7_0-1625483649954.png

@krishnakumars7 wrote:

But I can qliksense url for all the three sites, 

I meant, I can the qiksense hub from all three server, from where I tried scalability tool

Regards

Krishna Kumar S

Daniel_Larsson
Employee
Employee
Author

Hi,

I haven't seen that error message before, but see you are using the connect to app functionality. If you try executing  a script with same connection settings, do you get a different error or the same? The script itself could be a timerdelay only or something, important part is the connection settings and trying to execute it instead of using the "connect" functionality.