Skip to main content
YOUR OPINION MATTERS! Please take the Qlik Experience survey you received via email. Survey ends June 14.
Digital Support
Digital Support

Updated 1/05/2022 to include upgrading to NPrinting May 2021 Service Release 3 (SR3) will resolve issue. 

Hello All, 

Please be sure to upgrade to the latest NPrinting May 2021 Service Release, SR3, to resolve the issue stated below. 

The download site can be found here.


Detailed Release notes are attached and include Windows/Office updates in addition to publish tasks and source formatting issue resolutions. 




Original Post:

Hello Qlik NPrinting users,


We are currently facing an NPrinting Designer issue after the latest Windows/Office update and are actively working to resolve this defect.

After attempting to open the NPrinting Template Editor in NPrinting Designer you may see this error message: “Qlik NPrinting Designer can't find a supported reporting template editor for this file…”

The temporary workaround would be to revert to a prior version of Office. How to revert to an earlier version of Office (

We will continue to post updates on this thread as they become available. We appreciate your patience during this time.


Thank you,

Qlik Global Support

Partner - Contributor III
Partner - Contributor III
Microsoft recently updated the Windows office and registry and bugged the way Nprinting Designer works.
We apply the steps bellow em 3 environments and all works well.
1. Open Registry Windows
2. Go to HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\16.0\ (logged with the user run nprinting Designer and in this example using office version 16, check if is other version)
3. Delete Common key or Rename for Common.old
4. Create Common key
5. Right Click on Common key and go to Permission
6. Add everyone and Deny Full Control and Read and apply
7. For work test, try to create key inside the Common, we should see the error (permission is expected)
8. Now, try to edit report (does not require restart of server or anything, just open)
if anyone can validate I hope it helps
Partner - Contributor III
Partner - Contributor III

I've tried being more specific and figured out which key is causing the problem.

The following steps are required:

delete key: HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\16.0\Common\ExperimentConfigs

Recreate the HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\16.0\Common\ExperimentConfigs key

Edit permissions and block write and full control

More details below


Anyone having this problem, please, test the workaround provided in the "Preliminary Step" in this article:

Kindly, confirm that this resolves the issue.

Partner - Creator II
Partner - Creator II

Hi @Andrea_Bertazzo,

I confirm, this resolves all the issues. The step 3 of the link is necessary starting from Office version 2109.

Partner - Creator
Partner - Creator

I would suggest not to use the solution from @vinicius_rosa 

I applied this solution and it worked for getting NPrinting fully up and running again (in this case with Excel Office 365).

Unfortunately it messes up your complete Office registry. If you look at the different keys that are in the Common registry entry the suggestion was to rename it and create and empty Common one. Although it works, it happened to me that I was logged out of office and not able to login again. Then Office told me to activate my license but it did not work anymore.

We spend over 10 hours with Microsoft support to solve it and finally realize that this change in the registry was the root cause of Office not working correctly anymore.

I would suggest not using this at customers to avoid any major issues and wait for Qlik to come with a solution.

After reverting back the registry edit Office worked again for me.



@marcginqo the solution tested by R&D is in and it doesn't require to modify the registry.

Best Regards,


Partner - Contributor III
Partner - Contributor III

if the registry change is not the best way maybe you try to rollback Office365.

Using this link bellow to check all versions release by Microsoft

I used and works well version 14026.20308

Then running this commands in CMD (with administrative privileges)

cd C:\Program Files\Common Files\microsoft shared\ClickToRun

OfficeC2RClient.exe /update user updatetoversion=16.0.14026.20308