0 Replies Latest reply: Nov 12, 2014 12:03 AM by Ram Repala RSS

    Unable to open Qlikview document using webticket authentication

      Hi,

       

      We have QVWS and QVS to access the .qvw document for specified users. For testing purpose, we have couple of files and we made both files publish to the repository for all users (it is not set up for authorized users and/or named users).

       

      Here is my Configuration.

       

      On QVWS:

      Authentication: Always

      Type: Ntlm

      Login Address: Alternate Login page

       

      ON QVS:

      Security Tab: DMS Authentication...

       

      And we have set of IPs made as trussted list in Config.xml  on QVWS and one of them is below "serverip"

      And onemore thing, we have turned off section access as well.

       

      From my java application, I tried to get the webticket for a specific user using  "serverip" and got the ticket successfully.

      I used the same webticket to open the document btu never succeeded.

       

       

      We have below 2 urls to access the document on Qlikview server

       

      Loadbalancer one is:

       

      http://<serverip>/QvAJAXZfc/AccessPoint.aspx?open=&id=Customer%7CCUSTOMER%2FCUSTOMER_LERG.qvw&client=Aja

       

      Actual one is:

      http://<serverip>/QvAJAXZfc/opendoc.htm?document=CUSTOMER%2FCUSTOMER_LERG.qvw&host=Customer

       

      I have tried various ways to open the document as mentioned in various posts using webticket, but no luck..

       

      When I tried the below urls.. i got the Accesspoint screen(but no completed loaded)...

       

      http://<serverip>/QvAJAXZfc/Authenticate.aspx?type=html&webticket=issA7xUit+hHwNkzWNKojte66XTLJR1KDdVHH/ll&try=/QvAJAXZfc/opendoc.htm?document=CUSTOMER%2FCUSTOMER_LERG.qvw&host=Customer

       

      or

       

      http://<serverip>/QvAJAXZfc/Authenticate.aspx?type=html&webticket=issA7xUit+hHwNkzWNKojte66XTLJR1KDdVHH/ll&try=%2FQvAJAXZfc%2Fopendoc.htm%3Fdocument%3DCUSTOMER%252FCUSTOMER_LERG.qvw%26host%3DCustomer

       

      or

       

      http://<serverip>/QvAJAXZfc/Authenticate.aspx?type=html&webticket=2AyRbi3HmTTVLJxbWyor8GZFoHbeQbr6DAxhJOD4&try=/QvAJAXZfc/AccessPoint.aspx?open=&id=Customer%7CCUSTOMER%2FCUSTOMER_LERG.qvw&client=Ajax

       

      or

       

      http://<serverip>/QvAJAXZfc/Authenticate.aspx?type=html&webticket=2AyRbi3HmTTVLJxbWyor8GZFoHbeQbr6DAxhJOD4&try=%2FQvAJAXZfc%2FAccessPoint.aspx%3Fopen%3D%26id%3DCustomer%257CCUSTOMER%252FCUSTOMER_LERG.qvw%26client%3DAjax

       

       

      And when I tried with below url,

       

       

      http://<serverip>/qvajaxzfc/authenticate.aspx?type=html&try=/qvajaxzfc/opendoc.htm?document=CUSTOMER%2FCUSTOMER_LERG.qvw&host=Customer@<serverip>&keep=true&back=Login.htm&webticket=<WEBTICKET>

       

      I got the screen with  "loading....... ", but it never completed loading the page , but when I saw the view source, I could see that all the html content present.

       

      I am trying in various ways, but couldnt successful...either with HTTP Header authentication or with Webticket method..

      Please could you point me, where I am doing something wrong.

       

       

      Really I need this to be working very urgently...

      Your help is very grateful to me and much appreciated...

       

      Thanks,