7 Replies Latest reply: Dec 28, 2014 1:37 AM by Simone Spanio RSS

    General script error

    Laura Sébille

      Hello everyone,

       

      I am facing a curious problem. I hope someone will be able to help me.

       

      I have server D which is my developement server.  When I want to put an application in production, I paste it in server S which is my "storage" server.  Then, the Qlikview server runs the application that are stored in server S.

       

      I have an application which is store on server S. When I run it from server D, it works. But when I run it from Qlikview management console, it fails.

       

      I have already have that case and each time, it was because I let some absolute paths instead of relative...

       

      But this time it is not the case. 

       

      this is the piece of code where the app fails :

       

      STORE blabla into ..\QVD\QVD_PE\azer\blabla.qvd;

      Drop table blabla;

       

      This is what I've got in the journal after the application failed with QMC:

       

      26/12/2014 21:34:26: 3375  STORE blabla into ..\QVD\QVD_PE\azer\blabla.qvd

      26/12/2014 21:34:26:       General Script Error

      26/12/2014 21:34:26:       Execution Failed

      26/12/2014 21:34:27:      Execution finished.

       

      So the application fails just before the drop table statement. But the QVD is stored (I've checked it).

       

      Now I've tried to run it with one line in comment :

      //STORE blabla into ..\QVD\QVD_PE\azer\blabla.qvd;

      Drop table blabla;

       

      or

       

      STORE blabla into ..\QVD\QVD_PE\azer\blabla.qvd;

      //Drop table blabla;

       

      And in both cases, the reload works. It's only when there are these 2 statements that there is a failure.  I really don't get why...

       

      Do you have any ideas ?

       

      Please, do not hesitate to tell me if my problem is not clear..

       

       

      Thank you for your help