1 Reply Latest reply: Aug 5, 2015 8:44 PM by Jeffrey Goldberg RSS

    Accessing hub from client machine using admin credentials

      <@Posting the question in this forum as per @Michael Tarallo's direction>


      I have actually run into some sort of a roadblock with the user access pass thing. Will try to explain the situation to as clearly as possible:

       

      1. I have installed the qliksense server on an AWS machine which I connect through Remote Desktop Connection. I have also published an app on the same.

      2. I currently have only one user access pass allocated to the "administrator". Using this access pass, I am able to access both qmc and hub on the AWS machine.

      3. However, when I try to access qmc/hub from my local machine, it is not happening. I had changed the authentication method in Virtual proxy to "Allow anonymous users". Then, I was able to open hub but it gave me a "No access pass" error on the splash screen.

       

      So my question is, how can I access the qmc/hub using administrator credentials created on the AWS machine on my local machine?  Right now I am just doing a POC on the same and hence do not wish to use the other tokens.

       

      I hope I was able to clearly articulate my question.  Please let me know if more clarification is needed.

       

      regards,

      Saurav

        • Re: Accessing hub from client machine using admin credentials
          Jeffrey Goldberg

          HI Saurav,

           

          on your local machine, are you prompted to provide credentials?  If not, the issue may be an Internet Explorer setting.

           

          I'm seeing a lot of IE settings where the User authentication for the browser is set to Automatic Login either in the intranet zone or for all zones.

           

          What you want to do is change the setting to Prompt for user name and password.

          Here are some screen shots:

          2015-08-05 20_41_19-Qlik Central Home - Internet Explorer.png2015-08-05 20_41_36-Qlik Central Home - Internet Explorer.png

           

          Change to Prompt for user name and password for Internet, Intranet, and Trusted Zones Custom Level. Clear history and try again.  Keep in mind Chrome and Firefox use these settings as well, so even if you aren't using IE, you need to change through Internet Control Panel.

           

          I recommend turning off allow anonymous as well before testing.

           

          jg