4 Replies Latest reply: Mar 24, 2011 4:24 AM by Johann Choucq RSS

    LOAD Concatenate QVD not optimised

    Johann Choucq

      Hello everybody,

      I load one QVD File and then, I concatenate with another QVD File.

      I notice, that the second QVD load is not optimised although it is just a "LOAD * FROM QVD"

      Have you ever met this situation ?

      Regards,

      Johann

        • LOAD Concatenate QVD not optimised

          Hi Johann, this situation arise when you concatenate qvds that do not have the number of columns or the columns are named differently. I would suggest that you try to homologate the structure of the qvd's you are concatenating. You can also, implement partial loads by saving the result of the concatenation, so next time you concatenate the qvd's containing the new rows no extra columns be added with the concatenate function.

          Regards

            • LOAD Concatenate QVD not optimised
              Johann Choucq

              thanks a lot Ivan.

              what do you mean by "saving the result of the concatenation " ? You mean in an other QVD ?

              Regads

              Joh

                • LOAD Concatenate QVD not optimised

                   


                  jchoucq wrote:what do you mean by "saving the result of the concatenation " ? You mean in an other QVD ?


                  Yes, I mean saving the concatenated table in other QVD. I'm guessing you are concatenating transactions tables, so once you have a historical concatenated transactions table stored in a qvd you can add the new rows from your qvds without the pain of waiting for QlikView to create the columns that do not exisits in a particular qvd, this is the only way I found out to take advantage of optimized loading.

                  As I pointed before, the other feasable option is to homologate all your transactions qvd's to contain the same number of columns with the exact same column names. If you try this approach try not to use the null() function to populate the columns that do not exisist in a particular fact table, use empty string '' or zero-values instead; for some reason the null() function takes more disk space to be stored, at least it is what I remembered from that last implemetation.

                  Regards